summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/wmpuzzle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/wmpuzzle')
-rw-r--r--games-puzzle/wmpuzzle/Manifest1
-rw-r--r--games-puzzle/wmpuzzle/metadata.xml9
-rw-r--r--games-puzzle/wmpuzzle/wmpuzzle-0.5.2.ebuild48
3 files changed, 58 insertions, 0 deletions
diff --git a/games-puzzle/wmpuzzle/Manifest b/games-puzzle/wmpuzzle/Manifest
new file mode 100644
index 000000000000..8b3ead90953f
--- /dev/null
+++ b/games-puzzle/wmpuzzle/Manifest
@@ -0,0 +1 @@
+DIST wmpuzzle-0.5.2.tar.gz 87373 SHA256 b48b9ddb0b0bb85fd9fa3aef859984bce77b5f5faa6dad9366d00c1862a74b9b SHA512 7d171d307e3829005dff4d718161655785e87129b07917d494bb498eff904adafc7c6f83e71f996759ee9e365fe70c67858a5ec9d2647fe573e0a1505126f6c0 WHIRLPOOL 8d91e237b85ccc46ca27308f7c4e69b1cc00d9602d7e679fe6340d7442dc4c7a47c8b2bef07ae1ccc4c0998fdee0b54d55ccfa9c9dfe85eb55ec3a7a5ba93508
diff --git a/games-puzzle/wmpuzzle/metadata.xml b/games-puzzle/wmpuzzle/metadata.xml
new file mode 100644
index 000000000000..724fa31d6f78
--- /dev/null
+++ b/games-puzzle/wmpuzzle/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="freecode">wmpuzzle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/wmpuzzle/wmpuzzle-0.5.2.ebuild b/games-puzzle/wmpuzzle/wmpuzzle-0.5.2.ebuild
new file mode 100644
index 000000000000..dd8dad5db915
--- /dev/null
+++ b/games-puzzle/wmpuzzle/wmpuzzle-0.5.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="wmpuzzle provides a 4x4 puzzle on a 64x64 mini window"
+HOMEPAGE="http://freecode.com/projects/wmpuzzle"
+SRC_URI="http://people.debian.org/~godisch/wmpuzzle/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${P}/src
+
+src_install() {
+ dogamesbin ${PN}
+
+ dodoc ../{CHANGES,README}
+ newicon -s 48 numbers.xpm ${PN}.xpm
+ doman ${PN}.6
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ games_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ games_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}