summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-17 22:39:15 +0100
committerSam James <sam@gentoo.org>2022-06-17 23:49:06 +0100
commita7a34ec3f155cab724c8106e4375fd2fa08a347a (patch)
treee81c6073aa2aae4b00969c200547c3bf6dedd754 /games-engines
parentprofiles: add CeCILL-B license to @FSF-APPROVED (diff)
downloadgentoo-a7a34ec3f155cab724c8106e4375fd2fa08a347a.tar.gz
gentoo-a7a34ec3f155cab724c8106e4375fd2fa08a347a.tar.bz2
gentoo-a7a34ec3f155cab724c8106e4375fd2fa08a347a.zip
games-engines/odamex: fix build with GCC 12
Closes: https://bugs.gentoo.org/852566 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/odamex/files/odamex-10.0.0-gcc12.patch21
-rw-r--r--games-engines/odamex/odamex-10.0.0.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/games-engines/odamex/files/odamex-10.0.0-gcc12.patch b/games-engines/odamex/files/odamex-10.0.0-gcc12.patch
new file mode 100644
index 000000000000..8e1a080e1f90
--- /dev/null
+++ b/games-engines/odamex/files/odamex-10.0.0-gcc12.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/852566
+--- a/libraries/portmidi/pm_linux/finddefault.c
++++ b/libraries/portmidi/pm_linux/finddefault.c
+@@ -2,6 +2,7 @@
+ Roger Dannenberg, Jan 2009
+ */
+
++#include <ctype.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+--- a/master/main.cpp
++++ b/master/main.cpp
+@@ -29,6 +29,7 @@
+ #include <iostream>
+ #endif
+
++#include <ctime>
+ #include <string>
+ #include <vector>
+ #include <list>
diff --git a/games-engines/odamex/odamex-10.0.0.ebuild b/games-engines/odamex/odamex-10.0.0.ebuild
index 3f412be3f47d..bcaefbef7099 100644
--- a/games-engines/odamex/odamex-10.0.0.ebuild
+++ b/games-engines/odamex/odamex-10.0.0.ebuild
@@ -46,6 +46,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-10.0.0-unbundle-fltk.patch
"${FILESDIR}"/${PN}-10.0.0-musl.patch
"${FILESDIR}"/${PN}-10.0.0-master-std.patch
+ "${FILESDIR}"/${PN}-10.0.0-gcc12.patch
)
src_prepare() {