summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-emulation/stella
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-emulation/stella')
-rw-r--r--games-emulation/stella/Manifest1
-rw-r--r--games-emulation/stella/metadata.xml8
-rw-r--r--games-emulation/stella/stella-4.0.ebuild69
3 files changed, 78 insertions, 0 deletions
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
new file mode 100644
index 000000000000..bb3500f2f21a
--- /dev/null
+++ b/games-emulation/stella/Manifest
@@ -0,0 +1 @@
+DIST stella-4.0-src.tar.gz 2283736 SHA256 bc3445109a090360070644f249b7b6c8f73b6044606d77d65303538785d426c9 SHA512 42df4429dfbfc268e7b7d1c538641b443703ba2af4ad4e66b9df05f2b7d62a860a1895f738d95a3a0b879052865137d31a22b8611f3b93ff9746649553c099fa WHIRLPOOL f0e1433a509724f0a5725aefbd1bb277729e985a173551051c2bf39eeb279f19053f14d6fa384f1a0104de9d0f9cd6f49ffe84347fcd59edb42189e681772a95
diff --git a/games-emulation/stella/metadata.xml b/games-emulation/stella/metadata.xml
new file mode 100644
index 000000000000..a3b7e2075da3
--- /dev/null
+++ b/games-emulation/stella/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">stella</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/stella/stella-4.0.ebuild b/games-emulation/stella/stella-4.0.ebuild
new file mode 100644
index 000000000000..819e829098d0
--- /dev/null
+++ b/games-emulation/stella/stella-4.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stella/${P}-src.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="joystick"
+
+DEPEND="media-libs/libsdl2[joystick?,opengl,video]
+ media-libs/libpng:0
+ sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
+ Makefile || die
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ local i
+ for i in 16 22 24 32 48 64 128 ; do
+ newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
+ done
+
+ emake DESTDIR="${D}" install
+ domenu src/unix/stella.desktop
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}