summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-05 14:03:21 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-05 14:03:21 +0200
commitd3f96c91f541d187dc79e38fab6e2385f8135315 (patch)
tree1dfeabb772f286ee6bf16142df7e990662dc5167 /games-emulation/dgen-sdl
parentdev-perl/Clone: keyworded 0.450.0 for ppc64 (diff)
downloadgentoo-d3f96c91f541d187dc79e38fab6e2385f8135315.tar.gz
gentoo-d3f96c91f541d187dc79e38fab6e2385f8135315.tar.bz2
gentoo-d3f96c91f541d187dc79e38fab6e2385f8135315.zip
games-emulation/dgen-sdl: Fix compiling with clang
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-emulation/dgen-sdl')
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild1
-rw-r--r--games-emulation/dgen-sdl/files/dgen-sdl-1.33-clang-c++11.patch20
2 files changed, 21 insertions, 0 deletions
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
index c80d660bf3e8..3d541bd2cb8c 100644
--- a/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
@@ -24,6 +24,7 @@ BDEPEND="x86? ( dev-lang/nasm )"
PATCHES=(
"${FILESDIR}"/${P}-joystick.patch
"${FILESDIR}"/${P}-AM_PROG_AR.patch
+ "${FILESDIR}"/${P}-clang-c++11.patch
)
src_prepare() {
diff --git a/games-emulation/dgen-sdl/files/dgen-sdl-1.33-clang-c++11.patch b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-clang-c++11.patch
new file mode 100644
index 000000000000..55810b004f2c
--- /dev/null
+++ b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-clang-c++11.patch
@@ -0,0 +1,20 @@
+--- a/main.cpp
++++ b/main.cpp
+@@ -82,7 +82,7 @@
+ static void help()
+ {
+ printf(
+- "DGen/SDL v"VER"\n"
++ "DGen/SDL v" VER "\n"
+ "Usage: dgen [options] [romname [...]]\n\n"
+ "Where options are:\n"
+ " -v Print version number and exit.\n"
+@@ -256,7 +256,7 @@
+ {
+ case 'v':
+ // Show version and exit
+- printf("DGen/SDL version "VER"\n");
++ printf("DGen/SDL version " VER "\n");
+ return 0;
+ case 'r':
+ // Parse another RC file or stdin