summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/stockfish
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/stockfish')
-rw-r--r--games-board/stockfish/Manifest1
-rw-r--r--games-board/stockfish/metadata.xml14
-rw-r--r--games-board/stockfish/stockfish-6-r1.ebuild60
3 files changed, 75 insertions, 0 deletions
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
new file mode 100644
index 000000000000..9142b4d6d98b
--- /dev/null
+++ b/games-board/stockfish/Manifest
@@ -0,0 +1 @@
+DIST stockfish-6-src.zip 161183 SHA256 a69a371d3f84338cefde4575669bd930d186b046a10fa5ab0f8d1aed6cb204c3 SHA512 8381b7a8616281629f04c6dc4cbe5a279b06067f7af3faff271461f694122eeba9d83a0c4a295b9064142bcaa3b31eca8139b58eb9441684845aad45888402dc WHIRLPOOL 56672a5730ce1f9adef13b658e960f808a990752b749ab3c658e1dbdd54e81bbee9c32ab91c892cd6f8b91ad4d8fe5bcff2c5d0942616b5dda5e77c196ad5092
diff --git a/games-board/stockfish/metadata.xml b/games-board/stockfish/metadata.xml
new file mode 100644
index 000000000000..1f5c48a54c2b
--- /dev/null
+++ b/games-board/stockfish/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+ <use>
+ <flag name='armv7'>Build for armv7; enables PIE</flag>
+ <flag name='general-32'>Generic unoptimized 32-bits build</flag>
+ <flag name='general-64'>Generic unoptimized 64-bits build</flag>
+ <flag name='optimize'>Enable upstream -O3 optimizations (default enabled)</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-board/stockfish/stockfish-6-r1.ebuild b/games-board/stockfish/stockfish-6-r1.ebuild
new file mode 100644
index 000000000000..df819ce36600
--- /dev/null
+++ b/games-board/stockfish/stockfish-6-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/official-stockfish/Stockfish.git"
+ KEYWORDS=""
+ S=${WORKDIR}/${P}/src
+else
+ SRC_URI="https://stockfish.s3.amazonaws.com/${P}-src.zip"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${P}-src/src
+fi
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="http://stockfishchess.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="armv7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+ general-32 general-64 +optimize"
+
+DEPEND="|| ( app-arch/unzip
+ app-arch/zip )"
+RDEPEND=""
+
+src_prepare() {
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile || die
+}
+
+src_compile() {
+ local my_arch
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+ # other architectures
+ use armv7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ emake build ARCH=${my_arch} \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc ../AUTHORS ../Readme.md
+}