summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-19 01:45:50 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-19 02:11:36 -0500
commita5df7a6bd538972de65e8c1332bab7b11a27909d (patch)
tree246a8daf1902f94149fe8ffc12098e6e1ca84a20 /games-arcade
parentgames-arcade/rocksndiamonds: drop 4.1.4.1 (diff)
downloadgentoo-a5df7a6bd538972de65e8c1332bab7b11a27909d.tar.gz
gentoo-a5df7a6bd538972de65e8c1332bab7b11a27909d.tar.bz2
gentoo-a5df7a6bd538972de65e8c1332bab7b11a27909d.zip
games-arcade/xbill: drop 2.1-r5
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xbill/files/xbill-2.1-clang16.patch17
-rw-r--r--games-arcade/xbill/files/xbill-2.1-gtk2.patch18
-rw-r--r--games-arcade/xbill/xbill-2.1-r5.ebuild50
3 files changed, 0 insertions, 85 deletions
diff --git a/games-arcade/xbill/files/xbill-2.1-clang16.patch b/games-arcade/xbill/files/xbill-2.1-clang16.patch
index ee31ec657e4e..524fdde63ae4 100644
--- a/games-arcade/xbill/files/xbill-2.1-clang16.patch
+++ b/games-arcade/xbill/files/xbill-2.1-clang16.patch
@@ -25,20 +25,3 @@ https://bugs.gentoo.org/874624
#include <string.h>
+#include <strings.h>
---- a/gtk.c
-+++ b/gtk.c
-@@ -370,3 +370,3 @@
- gtk_signal_connect_object(GTK_OBJECT(menu_item), "activate",
-- gtk_ui_popup_dialog, (gpointer) dialog);
-+ GTK_SIGNAL_FUNC(gtk_ui_popup_dialog), (gpointer) dialog);
- return (menu_item);
-@@ -592,3 +592,3 @@
- CreateDialog(DIALOG_PAUSEGAME, 0, icon, "Continue", NULL);
-- CreateEnterText(DIALOG_WARPLEVEL, warp_apply);
-+ CreateEnterText(DIALOG_WARPLEVEL, GTK_SIGNAL_FUNC(warp_apply));
- CreateDialog(DIALOG_HIGHSCORE, 0, NULL, NULL, NULL);
-@@ -602,3 +602,3 @@
- CreateDialog(DIALOG_ENDGAME, 0, NULL, "Nuts!", NULL);
-- CreateEnterText(DIALOG_ENTERNAME, enter_name);
-+ CreateEnterText(DIALOG_ENTERNAME, GTK_SIGNAL_FUNC(enter_name));
- }
diff --git a/games-arcade/xbill/files/xbill-2.1-gtk2.patch b/games-arcade/xbill/files/xbill-2.1-gtk2.patch
deleted file mode 100644
index 829475badd72..000000000000
--- a/games-arcade/xbill/files/xbill-2.1-gtk2.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/configure.in 2007-12-05 22:37:57.000000000 +0100
-+++ b/configure.in 2007-12-05 22:54:57.000000000 +0100
-@@ -88,12 +88,11 @@
- [ --enable-gtk build with the GTK widget set])
-
- if test "$enable_gtk" != "no"; then
-- AC_CHECK_PROG(GTKCONFIG, gtk-config, yes, no)
-+ PKG_CHECK_MODULES(GTK, gtk+-2.0)
-
-- if test "X$GTKCONFIG" = X"yes"; then
-+ if test $pkg_failed = no; then
- AC_DEFINE(USE_GTK)
-- GTK_CFLAGS="`gtk-config --cflags`"
-- WIDGET_LIBS="$WIDGET_LIBS `gtk-config --libs`"
-+ WIDGET_LIBS="$WIDGET_LIBS $GTK_LIBS"
- WIDGET_OBJS="$WIDGET_OBJS gtk.o"
- fi
- fi
diff --git a/games-arcade/xbill/xbill-2.1-r5.ebuild b/games-arcade/xbill/xbill-2.1-r5.ebuild
deleted file mode 100644
index 2f21efed00bd..000000000000
--- a/games-arcade/xbill/xbill-2.1-r5.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools desktop
-
-DESCRIPTION="A game about an evil hacker called Bill!"
-HOMEPAGE="http://www.xbill.org/"
-SRC_URI="http://www.xbill.org/download/${P}.tar.gz"
-
-LICENSE="GPL-1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~x86"
-IUSE="gtk"
-
-RDEPEND="acct-group/gamestat
- media-fonts/font-misc-misc
- gtk? ( x11-libs/gtk+:2 )
- !gtk? ( x11-libs/libXaw )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gtk2.patch
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-clang16.patch
-)
-
-src_prepare() {
- default
- mv configure.in configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-motif \
- $(use_enable gtk) \
- $(use_enable !gtk athena)
-}
-
-src_install() {
- default
- newicon pixmaps/icon.xpm ${PN}.xpm
- make_desktop_entry ${PN} XBill ${PN}
-
- fowners :gamestat /var/lib/xbill/scores /usr/bin/${PN}
- fperms 664 /var/lib/xbill/scores
-}