summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/briquolo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/briquolo')
-rw-r--r--games-arcade/briquolo/Manifest1
-rw-r--r--games-arcade/briquolo/briquolo-0.5.7.ebuild56
-rw-r--r--games-arcade/briquolo/files/briquolo-0.5.7-gcc43.patch81
-rw-r--r--games-arcade/briquolo/files/briquolo-0.5.7-libpng14.patch31
-rw-r--r--games-arcade/briquolo/metadata.xml5
5 files changed, 174 insertions, 0 deletions
diff --git a/games-arcade/briquolo/Manifest b/games-arcade/briquolo/Manifest
new file mode 100644
index 000000000000..7d196e889668
--- /dev/null
+++ b/games-arcade/briquolo/Manifest
@@ -0,0 +1 @@
+DIST briquolo-0.5.7.tar.bz2 2588084 SHA256 061055dba524a784d6569fd74f3e4490db264da1356b53d68aae5523416f8f11 SHA512 4ef78193c80ac3554b72149b8da9b5cfd5b8fd68932e5b52666d74642e94a7a3a596dbb6d2865cba526929dd6d9be89743847d5e77b6fbc687c32394bc3be3d2 WHIRLPOOL d1c5f2a2502a6b8621f71d2034d5a34b12e45b6c6b2ce6baf83209c2806a306de6e183493193643d9224a86b0634fc9e2f31186131125ab15d3802a594aa7b51
diff --git a/games-arcade/briquolo/briquolo-0.5.7.ebuild b/games-arcade/briquolo/briquolo-0.5.7.ebuild
new file mode 100644
index 000000000000..2690ebcf66e1
--- /dev/null
+++ b/games-arcade/briquolo/briquolo-0.5.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="Breakout with 3D representation based on OpenGL"
+HOMEPAGE="http://briquolo.free.fr/en/index.html"
+SRC_URI="http://briquolo.free.fr/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/libpng
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
+ # no thanks we'll take care of it.
+ sed -i \
+ -e '/^SUBDIRS/s/desktop//' \
+ Makefile.in \
+ || die "sed Makefile.in failed"
+ sed -i \
+ -e "/CXXFLAGS/s:-O3:${CXXFLAGS}:" \
+ -e 's:=.*share/locale:=/usr/share/locale:' \
+ configure \
+ || die "sed configure failed"
+ sed -i \
+ -e 's:$(datadir)/locale:/usr/share/locale:' \
+ po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+}
+
+src_configure() {
+ egamesconf \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ doicon desktop/briquolo.svg
+ make_desktop_entry briquolo Briquolo
+ prepgamesdirs
+}
diff --git a/games-arcade/briquolo/files/briquolo-0.5.7-gcc43.patch b/games-arcade/briquolo/files/briquolo-0.5.7-gcc43.patch
new file mode 100644
index 000000000000..13e932a1c69e
--- /dev/null
+++ b/games-arcade/briquolo/files/briquolo-0.5.7-gcc43.patch
@@ -0,0 +1,81 @@
+diff -ru src.orig/Constante.cpp src/Constante.cpp
+--- src.orig/Constante.cpp 2008-03-22 05:40:33.000000000 -0400
++++ src/Constante.cpp 2008-06-11 23:16:46.000000000 -0400
+@@ -27,6 +27,7 @@
+ #define DATADIR_BRIQUOLO "./"
+ #define PACKAGE "briquolo"
+ #endif
++#include <cstdlib>
+
+ #ifdef WIN32
+ #define WIN32_LEAN_AND_MEAN
+diff -ru src.orig/MOGL/MOGL_EnsembleObjet.cpp src/MOGL/MOGL_EnsembleObjet.cpp
+--- src.orig/MOGL/MOGL_EnsembleObjet.cpp 2008-03-24 09:12:36.000000000 -0400
++++ src/MOGL/MOGL_EnsembleObjet.cpp 2008-06-11 23:17:11.000000000 -0400
+@@ -24,7 +24,8 @@
+ #include "MOGL_Armature.h"
+ #include "MOGL_Peau.h"
+ //#include
+-#include <stdio.h>
++#include <cstdio>
++#include <cstring>
+
+ //#include <mmsystem.h>
+
+diff -ru src.orig/MOGL/MOGL_GestionnaireObjet.cpp src/MOGL/MOGL_GestionnaireObjet.cpp
+--- src.orig/MOGL/MOGL_GestionnaireObjet.cpp 2008-03-24 08:56:13.000000000 -0400
++++ src/MOGL/MOGL_GestionnaireObjet.cpp 2008-06-11 23:18:45.000000000 -0400
+@@ -21,6 +21,7 @@
+ *****************************************************************************/
+ #include "../I18n.h"
+ #include "MOGL_GestionnaireObjet.h"
++#include <cstring>
+
+ bool MOGL_GestionnaireObjet::ChargerObjetASCTriangle(const char * p_NomFichier, const MOGL_GestionnaireTexture & p_GM,
+ MOGL_Objet & p_Objet)
+diff -ru src.orig/MOGL/MOGL_GestionnaireObjet.h src/MOGL/MOGL_GestionnaireObjet.h
+--- src.orig/MOGL/MOGL_GestionnaireObjet.h 2006-03-07 15:31:24.000000000 -0500
++++ src/MOGL/MOGL_GestionnaireObjet.h 2008-06-11 23:20:07.000000000 -0400
+@@ -24,7 +24,8 @@
+
+ #include <vector>
+ #include <iostream>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstring>
+
+ #include "MOGL_Triangle.h"
+ #include "MOGL_Objet.h"
+diff -ru src.orig/MOGL/MOGL_Image.h src/MOGL/MOGL_Image.h
+--- src.orig/MOGL/MOGL_Image.h 2006-03-07 15:53:11.000000000 -0500
++++ src/MOGL/MOGL_Image.h 2008-06-11 23:20:51.000000000 -0400
+@@ -24,6 +24,7 @@
+
+ #include "MOGL_Structure.h"
+ #include <string>
++#include <cstring>
+
+ using namespace std;
+
+diff -ru src.orig/MOGL/MOGL_Objet.cpp src/MOGL/MOGL_Objet.cpp
+--- src.orig/MOGL/MOGL_Objet.cpp 2006-03-07 15:31:24.000000000 -0500
++++ src/MOGL/MOGL_Objet.cpp 2008-06-11 23:21:05.000000000 -0400
+@@ -20,6 +20,7 @@
+ *
+ *****************************************************************************/
+ #include "MOGL_Objet.h"
++#include <cstdlib>
+
+ //MOGL_Objet::MOGL_Objet(): MOGL_ObjetAbstrait(), MOGL_ElementArbre()
+ MOGL_Objet::MOGL_Objet(): MOGL_Noeud(), _ModifieTriangle(true), _ModifieStrip(true),
+diff -ru src.orig/MOGL/MOGL_Peau.cpp src/MOGL/MOGL_Peau.cpp
+--- src.orig/MOGL/MOGL_Peau.cpp 2006-03-07 15:31:24.000000000 -0500
++++ src/MOGL/MOGL_Peau.cpp 2008-06-11 23:21:17.000000000 -0400
+@@ -20,6 +20,7 @@
+ *
+ *****************************************************************************/
+ #include "MOGL_Peau.h"
++#include <cstdlib>
+
+ MOGL_Peau::MOGL_Peau(): MOGL_Noeud(), _ModifieTriangle(true)
+ {
diff --git a/games-arcade/briquolo/files/briquolo-0.5.7-libpng14.patch b/games-arcade/briquolo/files/briquolo-0.5.7-libpng14.patch
new file mode 100644
index 000000000000..d325bac02578
--- /dev/null
+++ b/games-arcade/briquolo/files/briquolo-0.5.7-libpng14.patch
@@ -0,0 +1,31 @@
+http://bugs.gentoo.org/show_bug.cgi?id=308667
+
+--- src/MOGL/MOGL_Image.cpp
++++ src/MOGL/MOGL_Image.cpp
+@@ -183,7 +183,7 @@ bool MOGL_Image::ChargerPNG(const char *
+ info_ptr = png_create_info_struct(png_ptr);
+ if (info_ptr == NULL)
+ {
+- png_destroy_read_struct(&png_ptr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, NULL, NULL);
+ return false;
+ }
+
+@@ -191,7 +191,7 @@ bool MOGL_Image::ChargerPNG(const char *
+ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ // On libère la mémoire
+- png_destroy_read_struct(&png_ptr, &info_ptr, png_infopp_NULL);
++ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ return false;
+ }
+
+@@ -235,7 +235,7 @@ bool MOGL_Image::ChargerPNG(const char *
+ /* Expand grayscale images to the full 8 bits from 1, 2, or 4 bits/pixel */
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ /* Expand paletted or RGB images with transparency to full alpha channels
diff --git a/games-arcade/briquolo/metadata.xml b/games-arcade/briquolo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/briquolo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>