summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/blobwars
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/blobwars')
-rw-r--r--games-arcade/blobwars/Manifest1
-rw-r--r--games-arcade/blobwars/blobwars-1.19.ebuild75
-rw-r--r--games-arcade/blobwars/files/blobwars-1.19-ldflags.patch22
-rw-r--r--games-arcade/blobwars/files/blobwars-1.19-linking-order.patch36
-rw-r--r--games-arcade/blobwars/files/blobwars-1.19-zlib-1.2.5.2.patch22
-rw-r--r--games-arcade/blobwars/metadata.xml12
6 files changed, 168 insertions, 0 deletions
diff --git a/games-arcade/blobwars/Manifest b/games-arcade/blobwars/Manifest
new file mode 100644
index 000000000000..4c62d27a5b11
--- /dev/null
+++ b/games-arcade/blobwars/Manifest
@@ -0,0 +1 @@
+DIST blobwars-1.19.tar.gz 67019647 SHA256 f9bafe59ead9e370ceaba4aae3d280241bf05fa06c8ae006eec0322c2fe9e2ed SHA512 d31dcf5aae13bed849f701923cef7e829a43f199b8cde8dc9c28b283c8f7da6c5c8052387fae9add9f1bfb0c857c5be339b6049b6b19ff4c6c5ccbb6233e2643 WHIRLPOOL 4f4a31e80648696ee564be7b4aafddea666dd9cd7239e6310c03f873cb284a59beb40abaa4e8edd3da9e2dbb4dbf9f88cc1db3232b22aeadfda3cad5f473eea4
diff --git a/games-arcade/blobwars/blobwars-1.19.ebuild b/games-arcade/blobwars/blobwars-1.19.ebuild
new file mode 100644
index 000000000000..db013b19f276
--- /dev/null
+++ b/games-arcade/blobwars/blobwars-1.19.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Platform game about a blob and his quest to rescue MIAs from an alien invader"
+HOMEPAGE="http://sourceforge.net/projects/blobwars/ https://sourceforge.net/apps/mediawiki/blobwars/index.php?title=Main_Page"
+SRC_URI="mirror://sourceforge/blobwars/${P}.tar.gz"
+
+LICENSE="BSD CC-BY-SA-3.0 CC-BY-3.0 GPL-2 LGPL-2.1 fairuse public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.19-linking-order.patch \
+ "${FILESDIR}"/${PN}-1.19-ldflags.patch \
+ "${FILESDIR}"/${PN}-1.19-zlib-1.2.5.2.patch
+
+ sed -i -e "/-Werror/d" makefile || die
+}
+
+src_compile() {
+ emake \
+ USEPAK="1" \
+ DATADIR="${GAMES_DATADIR}/${PN}/" \
+ DOCDIR="/usr/share/doc/${PF}/html/" \
+ LOCALEDIR="/usr/share/locale/"
+}
+
+src_install() {
+ emake \
+ USEPAK="1" \
+ DESTDIR="${D}" \
+ BINDIR="${GAMES_BINDIR}/" \
+ DATADIR="${GAMES_DATADIR}/${PN}/" \
+ DOCDIR="/usr/share/doc/${PF}/html/" \
+ ICONDIR="/usr/share/icons/hicolor/" \
+ DESKTOPDIR="/usr/share/applications/" \
+ LOCALEDIR="/usr/share/locale/" \
+ install
+
+ mv -vf \
+ "${D}"/usr/share/doc/${PF}/html/{changes,hacking,porting,readme} \
+ "${D}"/usr/share/doc/${PF}/
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-arcade/blobwars/files/blobwars-1.19-ldflags.patch b/games-arcade/blobwars/files/blobwars-1.19-ldflags.patch
new file mode 100644
index 000000000000..8b006f1003a8
--- /dev/null
+++ b/games-arcade/blobwars/files/blobwars-1.19-ldflags.patch
@@ -0,0 +1,22 @@
+--- makefile~ 2011-08-29 20:32:22.000000000 +0200
++++ makefile 2011-08-29 20:33:27.052159159 +0200
+@@ -82,16 +82,16 @@
+
+ # linking the program.
+ $(PROG): $(GAMEOBJS)
+- $(CXX) $(GAMEOBJS) -o $(PROG) $(LIBS)
++ $(CXX) $(LDFLAGS) $(GAMEOBJS) -o $(PROG) $(LIBS)
+
+ pak: $(PAKOBJS)
+- $(CXX) $(PAKOBJS) -o pak $(LIBS)
++ $(CXX) $(LDFLAGS) $(PAKOBJS) -o pak $(LIBS)
+
+ %.mo: %.po
+ msgfmt -c -o $@ $<
+
+ mapeditor: $(MAPOBJS)
+- $(CXX) $(MAPOBJS) -o mapeditor $(LIBS)
++ $(CXX) $(LDFLAGS) $(MAPOBJS) -o mapeditor $(LIBS)
+
+ # cleaning everything that can be automatically recreated with "make".
+ clean:
diff --git a/games-arcade/blobwars/files/blobwars-1.19-linking-order.patch b/games-arcade/blobwars/files/blobwars-1.19-linking-order.patch
new file mode 100644
index 000000000000..6b0010138652
--- /dev/null
+++ b/games-arcade/blobwars/files/blobwars-1.19-linking-order.patch
@@ -0,0 +1,36 @@
+From 896cde549eeb254cc4960f20f54cab845e95b061 Mon Sep 17 00:00:00 2001
+From: Andreas Moog <amoog@ubuntu.com>
+Date: Sun, 19 Jun 2011 22:03:10 +0200
+Subject: [PATCH] LIBS go after objects to allow linking with ld --as-needed
+
+---
+ makefile | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/makefile b/makefile
+index 0a9cc94..509c2ff 100755
+--- a/makefile
++++ b/makefile
+@@ -82,16 +82,16 @@ all: $(ALL)
+
+ # linking the program.
+ $(PROG): $(GAMEOBJS)
+- $(CXX) $(LIBS) $(GAMEOBJS) -o $(PROG)
++ $(CXX) $(GAMEOBJS) -o $(PROG) $(LIBS)
+
+ pak: $(PAKOBJS)
+- $(CXX) $(LIBS) $(PAKOBJS) -o pak
++ $(CXX) $(PAKOBJS) -o pak $(LIBS)
+
+ %.mo: %.po
+ msgfmt -c -o $@ $<
+
+ mapeditor: $(MAPOBJS)
+- $(CXX) $(LIBS) $(MAPOBJS) -o mapeditor
++ $(CXX) $(MAPOBJS) -o mapeditor $(LIBS)
+
+ # cleaning everything that can be automatically recreated with "make".
+ clean:
+--
+1.7.5.4
+
diff --git a/games-arcade/blobwars/files/blobwars-1.19-zlib-1.2.5.2.patch b/games-arcade/blobwars/files/blobwars-1.19-zlib-1.2.5.2.patch
new file mode 100644
index 000000000000..cf101170e26c
--- /dev/null
+++ b/games-arcade/blobwars/files/blobwars-1.19-zlib-1.2.5.2.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/408459
+
+--- src/pak.cpp
++++ src/pak.cpp
+@@ -119,7 +119,7 @@
+ {
+ printf("Couldn't open %s for reading!\n", filename);
+ closedir(dirp);
+- gzclose(pak);
++ gzclose((gzFile)pak);
+ exit(1);
+ }
+
+@@ -141,7 +141,7 @@
+ {
+ printf("Couldn't open %s for reading!\n", filename);
+ closedir(dirp);
+- gzclose(pak);
++ gzclose((gzFile)pak);
+ exit(1);
+ }
+ else
diff --git a/games-arcade/blobwars/metadata.xml b/games-arcade/blobwars/metadata.xml
new file mode 100644
index 000000000000..6e3e4b851f2a
--- /dev/null
+++ b/games-arcade/blobwars/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">blobwars</remote-id>
+ </upstream>
+</pkgmetadata>