summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/hg-fast-export
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/hg-fast-export')
-rw-r--r--dev-vcs/hg-fast-export/Manifest2
-rw-r--r--dev-vcs/hg-fast-export/hg-fast-export-20140328.ebuild37
-rw-r--r--dev-vcs/hg-fast-export/hg-fast-export-20140706.ebuild39
-rw-r--r--dev-vcs/hg-fast-export/metadata.xml11
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-vcs/hg-fast-export/Manifest b/dev-vcs/hg-fast-export/Manifest
new file mode 100644
index 000000000000..515f9b636973
--- /dev/null
+++ b/dev-vcs/hg-fast-export/Manifest
@@ -0,0 +1,2 @@
+DIST hg-fast-export-20140328.tar.gz 14436 SHA256 a580dcd0ab2205de8e59cd3c46a23661799e433293b5a8d52179632eead0a690 SHA512 9eb7613634a176a5f273f5f86d0cdc544b360e98743866e47cf36859e1a84e95bb88b646e7c36d8671b7c7e61a0601684c38372c95aa173d324b897d6db7a39c WHIRLPOOL 1dd863a7685713fe244d71af1d7ffcbcb45a0904fad0cd31be64b524c7e5d37bd51ad13c11205eb587e606b57148f86041f334423d808335bf3137c46be9ce31
+DIST hg-fast-export-20140706.tar.gz 14671 SHA256 cab19797e7903fc7c6aeee00317d27608d1724837554c2dea47ac531b348cd73 SHA512 1c7421f6944af822dd0a6b8ac23c31f198b15da77a16773c5fd80371c3e059e1f45c1e67e5d88cfcf130e648252a76d923badf7fa2e0e3bd1a32e561c1c8f150 WHIRLPOOL 43d96daf9a77b18c7e7e2fe5375107a00e2b92f4ee1ed303534dfff42077b0a27c52ab65b89f308e3f5bda23f58a4f073537c60c69e94fed7f191e22bb04a49c
diff --git a/dev-vcs/hg-fast-export/hg-fast-export-20140328.ebuild b/dev-vcs/hg-fast-export/hg-fast-export-20140328.ebuild
new file mode 100644
index 000000000000..d773433d5955
--- /dev/null
+++ b/dev-vcs/hg-fast-export/hg-fast-export-20140328.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 vcs-snapshot
+
+COMMIT="779e2f6da887729fc513f5efceaa3a3083858c9b"
+DESCRIPTION="mercurial to git converter using git-fast-import"
+HOMEPAGE="https://github.com/frej/fast-export"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ sed -e '/^PYTHON/s/python/&2/' \
+ -e 's/PYTHON/E&/g' \
+ -i "${PN}".sh || die
+ rm Makefile || die #don't compile old svn2git code
+}
+
+src_install() {
+ newbin "${PN}".sh "${PN}"
+ python_foreach_impl python_doexe "${PN}".py
+ python_foreach_impl python_domodule hg2git.py
+}
diff --git a/dev-vcs/hg-fast-export/hg-fast-export-20140706.ebuild b/dev-vcs/hg-fast-export/hg-fast-export-20140706.ebuild
new file mode 100644
index 000000000000..7763dc633ba1
--- /dev/null
+++ b/dev-vcs/hg-fast-export/hg-fast-export-20140706.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 vcs-snapshot
+
+COMMIT="2c21922ad1795e1d305dac6bdb977f2e50eb809e"
+DESCRIPTION="mercurial to git converter using git-fast-import"
+HOMEPAGE="https://github.com/frej/fast-export"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ sed -e '/^PYTHON/s/python/&2.7/' \
+ -e '/^PYTHON/s/PYTHON:/E&/g' \
+ -e "/^ROOT/s:=.*:='${EPREFIX}/usr/bin':" \
+ -i "${PN}".sh || die
+ rm Makefile || die #don't compile old svn2git code
+}
+
+src_install() {
+ newbin "${PN}".sh "${PN}"
+ dodoc README
+ python_foreach_impl python_doexe "${PN}".py
+ python_foreach_impl python_domodule hg2git.py
+}
diff --git a/dev-vcs/hg-fast-export/metadata.xml b/dev-vcs/hg-fast-export/metadata.xml
new file mode 100644
index 000000000000..60462d91cb20
--- /dev/null
+++ b/dev-vcs/hg-fast-export/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">frej/fast-export</remote-id>
+ </upstream>
+</pkgmetadata>