summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/xxdi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/xxdi')
-rw-r--r--dev-util/xxdi/Manifest1
-rw-r--r--dev-util/xxdi/metadata.xml30
-rw-r--r--dev-util/xxdi/xxdi-1.0.0.ebuild26
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/xxdi/Manifest b/dev-util/xxdi/Manifest
new file mode 100644
index 000000000000..3e4bced4e862
--- /dev/null
+++ b/dev-util/xxdi/Manifest
@@ -0,0 +1 @@
+DIST xxdi-1.0.0.tar.gz 8039 SHA256 5279cd356a680ef22dafc13a8b674eafa81c2bc82f57b38b04059b16c046f1b0 SHA512 ebf026f61f0b0a339e3dfa5c9dd6a819ef23f0d29948073cbf5f6ae9668e68a7dd903f695ab5a824494f8424dad8b79aace5742bc23484a25303a15aa32ab698 WHIRLPOOL ed3199facbd8cdef6f37e8e595d6c91d994e0fdbe449ab95e4db6bb95e1ae6f0ed0c8650281a7aab9de7d22e8ef9f96dfb9383716043a99ca4c6ebbfd815248a
diff --git a/dev-util/xxdi/metadata.xml b/dev-util/xxdi/metadata.xml
new file mode 100644
index 000000000000..f4afb903d1d8
--- /dev/null
+++ b/dev-util/xxdi/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>gregkh@gentoo.org</email>
+ <name>Greg Kroah-Hartman</name>
+ <description>Maintainer, assign bugs to him.</description>
+ </maintainer>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ <description>Backup maintainer, CC him on bugs.</description>
+ </maintainer>
+ <longdescription lang="en">
+ xxdi.pl is a perl script that implements vim's 'xxd -i' mode
+ so that packages do not have to use all of vim just to get this
+ functionality.
+
+ efitools is an example of a package that uses it in this manner,
+ and in some build configurations, mediastreamer also does.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>gregkh@linuxfoundation.org</email>
+ <name>Greg Kroah-Hartman</name>
+ </maintainer>
+ <bugs-to>https://github.com/gregkh/xxdi/issues</bugs-to>
+ <remote-id type="github">gregkh/xxdi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/xxdi/xxdi-1.0.0.ebuild b/dev-util/xxdi/xxdi-1.0.0.ebuild
new file mode 100644
index 000000000000..897ce7252cea
--- /dev/null
+++ b/dev-util/xxdi/xxdi-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_VERSION=001
+
+DESCRIPTION="Simple alternative to vim's 'xxd -i' mode"
+HOMEPAGE="https://github.com/gregkh/xxdi"
+SRC_URI="https://github.com/gregkh/xxdi/archive/v${MODULE_VERSION}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/File-Slurp"
+
+S=${WORKDIR}/${PN}-${MODULE_VERSION}
+
+src_install() {
+ dobin xxdi.pl
+ dodoc README.md
+}