summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/csup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/csup')
-rw-r--r--dev-util/csup/Manifest1
-rw-r--r--dev-util/csup/csup-20060318.ebuild46
-rw-r--r--dev-util/csup/files/csup-20060318-respectflags.patch43
-rw-r--r--dev-util/csup/metadata.xml6
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-util/csup/Manifest b/dev-util/csup/Manifest
new file mode 100644
index 000000000000..838edf46958a
--- /dev/null
+++ b/dev-util/csup/Manifest
@@ -0,0 +1 @@
+DIST csup-snap-20060318.tgz 78968 SHA256 81a9695be6cf989de6fb2e4fe53d6efadb003cd842cf6993844a52fc8190a7fc SHA512 60e40f6f903df81b1667af31397978ce99d33b6849dd2476232b325415a391e6840a29e70af85b928a3c7beea55cf3064d3b48d61b9c20c2280dc3f675adcd5a WHIRLPOOL 52236475e56ea2a2ebc84f1d67b2327f1ab2d78fcde82133a4e5725a88bb62c3802a2fa030f1f67b14f35c8d5db380ac4361af4e4d063a39ed2ebe6b994f51c6
diff --git a/dev-util/csup/csup-20060318.ebuild b/dev-util/csup/csup-20060318.ebuild
new file mode 100644
index 000000000000..5a44ca644f54
--- /dev/null
+++ b/dev-util/csup/csup-20060318.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A rewrite of CVSup"
+HOMEPAGE="http://www.mu.org/~mux/csup.html"
+SRC_URI="http://mu.org/~mux/csup-snap-${PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ !>=sys-freebsd/freebsd-ubin-6.2_beta1"
+
+DEPEND="${DEPEND}
+ >=sys-devel/bison-2.1"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-respectflags.patch"
+}
+
+src_compile() {
+ # unable to work with yacc, but bison is ok.
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX=/usr YACC=bison || die "emake failed"
+}
+
+src_install() {
+ # instead of using make install, just copy the stuff directly
+ dobin csup || die "failed to install executable"
+ doman csup.1 || die "failed to install man page"
+ dodoc README
+}
diff --git a/dev-util/csup/files/csup-20060318-respectflags.patch b/dev-util/csup/files/csup-20060318-respectflags.patch
new file mode 100644
index 000000000000..c95a974c75ed
--- /dev/null
+++ b/dev-util/csup/files/csup-20060318-respectflags.patch
@@ -0,0 +1,43 @@
+Index: csup/GNUmakefile
+===================================================================
+--- csup.orig/GNUmakefile
++++ csup/GNUmakefile
+@@ -21,7 +21,7 @@ WARNS= -Wall -W -Wno-unused-parameter -W
+ -Wcast-align -Wunused-parameter -Wchar-subscripts -Winline \
+ -Wnested-externs -Wredundant-decls -Wno-format-y2k
+
+-CFLAGS+= -g -O -pipe -DNDEBUG -I$(PREFIX)/include
++CFLAGS+= -I$(PREFIX)/include
+ ifeq ($(UNAME), Linux)
+ CFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ endif
+@@ -29,14 +29,14 @@ ifeq ($(UNAME), Darwin)
+ CFLAGS+= -DHAVE_FFLAGS
+ endif
+ CFLAGS+= $(WARNS)
+-LDFLAGS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
++LIBS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
+
+ .PHONY: all clean install
+
+ all: csup csup.1.gz
+
+ csup: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $^ $(LIBS)
+
+ config.c: parse.h
+
+Index: csup/Makefile
+===================================================================
+--- csup.orig/Makefile
++++ csup/Makefile
+@@ -11,7 +11,7 @@ SRCS= attrstack.c config.c detailer.c di
+ globtree.c idcache.c keyword.c lister.c main.c misc.c mux.c parse.y \
+ pathcomp.c proto.c status.c stream.c threads.c token.l updater.c
+
+-CFLAGS+= -I. -I${.CURDIR} -g -pthread -DHAVE_FFLAGS -DNDEBUG
++CFLAGS+= -I. -I${.CURDIR} -pthread -DHAVE_FFLAGS
+ WARNS?= 6
+
+ # A bit of tweaking is needed to get this Makefile working
diff --git a/dev-util/csup/metadata.xml b/dev-util/csup/metadata.xml
new file mode 100644
index 000000000000..6457f0d2d37c
--- /dev/null
+++ b/dev-util/csup/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>bsd</herd>
+</pkgmetadata>
+