summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/crosstex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/crosstex')
-rw-r--r--dev-tex/crosstex/Manifest1
-rw-r--r--dev-tex/crosstex/crosstex-0.6.ebuild51
-rw-r--r--dev-tex/crosstex/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-tex/crosstex/Manifest b/dev-tex/crosstex/Manifest
new file mode 100644
index 000000000000..d5098ef47b57
--- /dev/null
+++ b/dev-tex/crosstex/Manifest
@@ -0,0 +1 @@
+DIST crosstex-0.6.tar.gz 2366411 SHA256 86a52ca110848faa66ec3cf0ef851b3591bbac46b50fee3d63399df493957473 SHA512 88d42ddbe4b229838c0750bbaf6d099349679a66859e8c28e03888d06bbc4641dd815a37e167700f6494a53e950245af864ea260a7779c3fd50e65cd968de08c WHIRLPOOL fb25ceb4d756c1e0cdedeedf48a442a09502245f63f7d5edfd179496f3229e34ba27268e593b0a30300460127e15d48dfdd692f95374a2aca7793b3a34230b6e
diff --git a/dev-tex/crosstex/crosstex-0.6.ebuild b/dev-tex/crosstex/crosstex-0.6.ebuild
new file mode 100644
index 000000000000..5ed8a14e5bd0
--- /dev/null
+++ b/dev-tex/crosstex/crosstex-0.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit multilib python
+
+DESCRIPTION="CrossTeX - object oriented BibTeX replacement"
+HOMEPAGE="http://www.cs.cornell.edu/people/egs/crosstex/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/ply"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ emake \
+ ROOT="${D}" \
+ PREFIX="/usr" \
+ LIBDIR="/$(get_libdir)/python$(python_get_version)/site-packages" \
+ install || die "emake install failed"
+
+ python_convert_shebangs -r $(python_get_version) "${D}"
+ python_need_rebuild
+
+ insinto /usr/share/doc/${PF}
+ doins "${PN}".pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}
diff --git a/dev-tex/crosstex/metadata.xml b/dev-tex/crosstex/metadata.xml
new file mode 100644
index 000000000000..76b8496bb50b
--- /dev/null
+++ b/dev-tex/crosstex/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <upstream>
+ <remote-id type="sourceforge">crosstex</remote-id>
+ </upstream>
+</pkgmetadata>