summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-02-04 07:34:18 +0100
committerHans de Graaff <graaff@gentoo.org>2016-02-04 07:34:18 +0100
commit4b4a9d2d18f521936d1baf7f2fccd55199d453a5 (patch)
tree345f75ca8bcc772229133e9f12d537c37b67138a /dev-ruby/unf_ext
parentdev-ruby/unf_ext: cleanup (diff)
downloadgentoo-4b4a9d2d18f521936d1baf7f2fccd55199d453a5.tar.gz
gentoo-4b4a9d2d18f521936d1baf7f2fccd55199d453a5.tar.bz2
gentoo-4b4a9d2d18f521936d1baf7f2fccd55199d453a5.zip
dev-ruby/unf_ext: add 0.0.7.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/unf_ext')
-rw-r--r--dev-ruby/unf_ext/Manifest1
-rw-r--r--dev-ruby/unf_ext/unf_ext-0.0.7.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/unf_ext/Manifest b/dev-ruby/unf_ext/Manifest
index 6f5dac18cbd6..82a7b8d85040 100644
--- a/dev-ruby/unf_ext/Manifest
+++ b/dev-ruby/unf_ext/Manifest
@@ -1 +1,2 @@
DIST unf_ext-0.0.7.1.gem 392192 SHA256 ab58d1a808d38872817bea89fc3f055bfc250af48d9653425e35c7c18caec253 SHA512 06239dc5870ad0f345266b12ad6ed9508ab731dfd37b450d0e1eae1ef8e8301f8ad1ef7fffbbcf69b56b0af5aa257ea279dda3a252bdf397d11949e9885db3d4 WHIRLPOOL 4d5d8c6efb46bb46b65967101389b5b7414bfa507d591e29dfb9d8c354555b9b92a997f19b68e0d4aa58143bf836849f152dafc2936b13a11cac74d7063f3d16
+DIST unf_ext-0.0.7.2.gem 392192 SHA256 e8fa13d09880f8d06d30a86f929a38ba0af6abe61272927a49e6796aee1aa111 SHA512 99e1cada3cc51baf52010b7569f68eff168dfb4c691645c88625738513258191e586e5d99f5ba7f528ce677fdec77a08510f77d9bf2c9234c68ac239f270fbf6 WHIRLPOOL 2e932abce52f87709dbf5f25ba8a7a32bd55410ba10b620db4d23a41855faf0da3486674ea7e9fb11849f9621d0fdbab8739c0486278026ba9e8f27ae47f5332
diff --git a/dev-ruby/unf_ext/unf_ext-0.0.7.2.ebuild b/dev-ruby/unf_ext/unf_ext-0.0.7.2.ebuild
new file mode 100644
index 000000000000..c4a1c03749ae
--- /dev/null
+++ b/dev-ruby/unf_ext/unf_ext-0.0.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem multilib
+
+DESCRIPTION="Unicode Normalization Form support library for CRuby"
+HOMEPAGE="http://sourceforge.jp/projects/unf/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/ s:^:#:' Rakefile test/helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/unf_ext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/unf_ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/unf_ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}