summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-01-22 09:22:48 +0100
committerHans de Graaff <graaff@gentoo.org>2023-01-22 09:30:11 +0100
commit939491141279879b3e10e0696344bdf293de52b0 (patch)
tree7f04de9b418c7622bfe834e4f8289d0af43687d1 /dev-ruby/pry
parentdev-ruby/ox: add 2.14.13 (diff)
downloadgentoo-939491141279879b3e10e0696344bdf293de52b0.tar.gz
gentoo-939491141279879b3e10e0696344bdf293de52b0.tar.bz2
gentoo-939491141279879b3e10e0696344bdf293de52b0.zip
dev-ruby/pry: add 0.14.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pry')
-rw-r--r--dev-ruby/pry/Manifest1
-rw-r--r--dev-ruby/pry/pry-0.14.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/pry/Manifest b/dev-ruby/pry/Manifest
index 0eaac44be6b0..884d8b1c62f6 100644
--- a/dev-ruby/pry/Manifest
+++ b/dev-ruby/pry/Manifest
@@ -1 +1,2 @@
DIST pry-0.14.1.tar.gz 239261 BLAKE2B 46bba71668cbfcb710ebf4f8921d1b4cbaad887b1546b4566a90f9f246f1ff41451ccabb4a8692bb8a404532227aaa72b2d530fa4451bf1b7141cb6f57dfea1a SHA512 b258d1ae7ffd82c6fbed7edbd6e9bc64006eb54e3376a2f85b7482e0517be34efb46a2264975820cac3b7c0bea89b855b4d2a6fb104ff760f25667e1afb3ba44
+DIST pry-0.14.2.tar.gz 239170 BLAKE2B a6370affcee671b293f33f65613607009d46b361fa241e47a1828c85e484dc82909ab8d307c2d20545253dd19115875788d1ab151b793e90246df4a7fec28cff SHA512 890ab8399899864c109919637e2641cafaf2d895db6ab4912bf856799708e08a68f4c9fbb5c505a75c160af30c4eabccfd52fa92cfa1dd3be7ae776ba0476660
diff --git a/dev-ruby/pry/pry-0.14.2.ebuild b/dev-ruby/pry/pry-0.14.2.ebuild
new file mode 100644
index 000000000000..1ac6df00cb29
--- /dev/null
+++ b/dev-ruby/pry/pry-0.14.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby"
+HOMEPAGE="https://github.com/pry/pry/wiki"
+SRC_URI="https://github.com/pry/pry/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+SLOT="ruby19"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+ruby_add_rdepend "
+ >=dev-ruby/coderay-1.1:0
+ =dev-ruby/method_source-1*"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/open4-1.3
+ >=dev-ruby/rake-0.9
+ >=dev-ruby/mocha-1.0
+ )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on git.
+ # Loosen coderay dependency.
+ sed -e '/git ls-files/d' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -e '/[Bb]undler/d' -i spec/spec_helper.rb || die
+
+ # Skip integration tests because they depend to much on specifics of the environment.
+ rm -f spec/integration/* || die
+ sed -i -e '/loads files through repl and exits/askip "depends on parent directory"' spec/cli_spec.rb || die
+}