summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-11-25 16:51:54 -0500
committerAaron Bauman <bman@gentoo.org>2018-11-25 16:51:54 -0500
commit57fc5aa90c123f61011a95bf19c5f6df4ae11120 (patch)
tree26247ce4641ecb8cb8cf189da2fb75bb7fe43f12 /dev-ruby/em-websocket
parentgames-emulation/dolphin: enable USE=egl unconditionally (diff)
downloadgentoo-57fc5aa90c123f61011a95bf19c5f6df4ae11120.tar.gz
gentoo-57fc5aa90c123f61011a95bf19c5f6df4ae11120.tar.bz2
gentoo-57fc5aa90c123f61011a95bf19c5f6df4ae11120.zip
dev-ruby/em-websocket: new package. supports www-apps/jekyll bump
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-ruby/em-websocket')
-rw-r--r--dev-ruby/em-websocket/Manifest1
-rw-r--r--dev-ruby/em-websocket/em-websocket-0.5.1.ebuild36
-rw-r--r--dev-ruby/em-websocket/metadata.xml11
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/em-websocket/Manifest b/dev-ruby/em-websocket/Manifest
new file mode 100644
index 000000000000..1d6e1bc1ba13
--- /dev/null
+++ b/dev-ruby/em-websocket/Manifest
@@ -0,0 +1 @@
+DIST em-websocket-0.5.1.tar.gz 27792 BLAKE2B 5aa8b9b9a1bf7066086c3115358a01054dbd24c3b9e7b454210c653aa25face2230e5504e0fc3a13d4770bcfcdf5d792c1914f173ec8d83d1b97ee7c169636af SHA512 ca2b4e2e4be663a5932fe63ed0efab169fbee9aec50f9780c1ee5df0efa300acb58410b97a22d5d10a2cb9195c2a68f6c71bf4e070ee6d915c6abf4015aa5d94
diff --git a/dev-ruby/em-websocket/em-websocket-0.5.1.ebuild b/dev-ruby/em-websocket/em-websocket-0.5.1.ebuild
new file mode 100644
index 000000000000..9e941fc5e43c
--- /dev/null
+++ b/dev-ruby/em-websocket/em-websocket-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="EventMachine based WebSocket server"
+HOMEPAGE="https://rubygems.org/gems/em-websocket"
+SRC_URI="https://github.com/igrigorik/em-websocket/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+ruby_add_rdepend "
+ >=dev-ruby/eventmachine-0.5
+ >=dev-ruby/http_parser_rb-0.6.0
+"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/em-websocket/metadata.xml b/dev-ruby/em-websocket/metadata.xml
new file mode 100644
index 000000000000..6c8849498569
--- /dev/null
+++ b/dev-ruby/em-websocket/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">igrigorik/em-websocket</remote-id>
+ </upstream>
+</pkgmetadata>