summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-10-10 04:55:29 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-10-10 10:49:24 -0400
commit4df220252b23c77b5683dc93eb9aaebd4666504a (patch)
tree9ff4da8929d20354c01785955d8c318445358e56 /dev-qt/qtspeech
parentdev-qt/qtshadertools: add 6.6.0 (diff)
downloadgentoo-4df220252b23c77b5683dc93eb9aaebd4666504a.tar.gz
gentoo-4df220252b23c77b5683dc93eb9aaebd4666504a.tar.bz2
gentoo-4df220252b23c77b5683dc93eb9aaebd4666504a.zip
dev-qt/qtspeech: add 6.6.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtspeech')
-rw-r--r--dev-qt/qtspeech/Manifest1
-rw-r--r--dev-qt/qtspeech/qtspeech-6.6.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index c87a3e61585d..5b02fb001f91 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -4,3 +4,4 @@ DIST qtspeech-everywhere-opensource-src-5.15.10.tar.xz 104944 BLAKE2B 7e664719d3
DIST qtspeech-everywhere-opensource-src-5.15.11.tar.xz 104996 BLAKE2B 3272a72d8073023631c3ac18734c672b2cde2f382a011d9f02d6604093454ab7d308c0d5141d0488eb953262e8beb46e0aa1616d86db4ebabfdc3366eab32b4d SHA512 658eb9d24ea2f2bf39c6f4cd6dc75677067c8058cae694b53e665e28a273d2f730ab0dd4744ca8f8db224e52bb014fd145af1abd1667e3cd37f74c51bf96ebf4
DIST qtspeech-everywhere-src-6.5.2.tar.xz 249568 BLAKE2B af86153ea1cf0f248ab80aa828a0457e23e1f97cc5ae91bf60fa426a43a44247230b643ae48e6ae839668ea9a66edc94e0358502abcab03788cd7d1368403592 SHA512 bc6ca225f9eadc838e63bb3b011f604c1ae18eee76445c2c0d22152e473b9316b6903e349aee2555c5a110ef65fbd25ca9065b22ae4cef6e5290daa665c78434
DIST qtspeech-everywhere-src-6.5.3.tar.xz 250112 BLAKE2B fd33ced6cd415e24789bfede90563f68e3bb63319766cb60ffb7f0708ac5f092f5cccafa840565bea6d52e5aeadd226eece9993be9f0132b65b8cabe8764a65d SHA512 d37c68cb9599e8d9a81ac070a87ed5a942e15e01401b5e179b4127aa0894a272023d717f0fc5f5c167e2ff299f79d6a19f3594172cf9779b400ac218d9587508
+DIST qtspeech-everywhere-src-6.6.0.tar.xz 270044 BLAKE2B 754a160963415fcdd764290cfac1314ddac0ef34ddf44d429cabe594a0056b29bfc71d5c746c07a45f729ef4e56ca2551bdd38b940e982c919b23fea6e5146fc SHA512 29fc5e2401ac0d184ca5931c86eba152d33433ef60e91e3c30fdce79438e13f89b9f7ea01452c528fabd24425a9396c6d6f18b8d7d085a002073f0d27ec2a56a
diff --git a/dev-qt/qtspeech/qtspeech-6.6.0.ebuild b/dev-qt/qtspeech/qtspeech-6.6.0.ebuild
new file mode 100644
index 000000000000..e8a12770ddf0
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-6.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Text-to-speech library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="flite qml +speechd"
+# can build with neither, but then it is just mock tts and may be confusing
+REQUIRED_USE="|| ( flite speechd )"
+
+# TODO: tests are known failing with clang and needs looking into, albeit
+# it is still usable at runtime save for applications segfaulting on exit
+# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
+# of this). Restricting because also seen this result in hanging. Note that
+# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
+# status on new major versions.
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtmultimedia-${PV}:6
+ flite? ( app-accessibility/flite )
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ speechd? ( app-accessibility/speech-dispatcher )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ $(qt_feature flite)
+ $(qt_feature speechd)
+
+ # flite_alsa was likely to work around old issues in flite, it does
+ # nothing but add -lasound (no code change, and is unneeded)
+ -DQT_FEATURE_flite_alsa=OFF
+ )
+
+ qt6-build_src_configure
+}