summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-16 11:25:20 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-16 12:31:35 +0100
commitb53383e7ac9b169bd6cdbb4e0f062c4d8ddb1acd (patch)
treef8900cd3f32a9d85d36a0269cb42e83125f8f78b /dev-python
parentdev-python/sentry-sdk: Bump to 1.12.0 (diff)
downloadgentoo-b53383e7ac9b169bd6cdbb4e0f062c4d8ddb1acd.tar.gz
gentoo-b53383e7ac9b169bd6cdbb4e0f062c4d8ddb1acd.tar.bz2
gentoo-b53383e7ac9b169bd6cdbb4e0f062c4d8ddb1acd.zip
dev-python/rope: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.6.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 1e5b748c9f7f..f85951b6cd7f 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,2 +1,3 @@
DIST rope-1.4.0.tar.gz 287417 BLAKE2B d161e571649be2df7e6012336e7bded844f98f67764740814bfccebc926ff4c5f734cdf26701c9b7cec35bf3178be1f1ebe0d86f3b60259a161d3e87125fc7d5 SHA512 586f6f22fdf4743f71bf7f7505ec49aaced28aff48b5eae4f731eb690edec1ff8c736e3f9f21d7732bf5ea60ced5253e8f0d224a51a6a9bfdf7dd50ab56733ea
DIST rope-1.5.1.tar.gz 288965 BLAKE2B bc912932dec03317a3ea24d2e15f751037d308d58a941305b6155e2f85d2ee81fc82f9d4183a1a416ebda6e791ab8c5408835e7eb36a7fb5a8b71116d5edb24c SHA512 5b7c76f0bfd481978d0e6c23d37f17f9db49fe6affc0f670868deed9a23a95c53f31a578bc7b8cd1c59318b38789a6e264f8fa9d3c7e13e5ce3db80dbadf177f
+DIST rope-1.6.0.tar.gz 289325 BLAKE2B fc7fc37a93f6d011f7e5eab5d2a28e3eab1767839cba4bce2b665c7972d6485eb3693e5977abfd36025415bc898fb4985affb7ac757c8457840a5de3946df77d SHA512 f610eb71c20533907aeea86c3ec5101401cf8136aba4221b2d64db3b0db16d4d7d1ec081c6d4929d6534ed51d4c01761af8d2ffddb6b69b4a9cc4921d240d745
diff --git a/dev-python/rope/rope-1.6.0.ebuild b/dev-python/rope/rope-1.6.0.ebuild
new file mode 100644
index 000000000000..be67d9231d44
--- /dev/null
+++ b/dev-python/rope/rope-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)