summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-06 23:16:22 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-06 23:16:22 +0200
commit4a0ca0be701e8557f9541bd29aae91a8fa9f2523 (patch)
treec64f0117f6c6ec4ce8549e0ea0f232cd33bf2e7a /dev-python
parentpackage.mask: Masked older virtualbox versions (bug #600214). (diff)
downloadgentoo-4a0ca0be701e8557f9541bd29aae91a8fa9f2523.tar.gz
gentoo-4a0ca0be701e8557f9541bd29aae91a8fa9f2523.tar.bz2
gentoo-4a0ca0be701e8557f9541bd29aae91a8fa9f2523.zip
dev-python/pysolr: version bump.
Gentoo-Bug: https://bugs.gentoo.org/591128 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysolr/Manifest1
-rw-r--r--dev-python/pysolr/pysolr-3.5.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pysolr/Manifest b/dev-python/pysolr/Manifest
index 5a2f94e032ba..60b64493dfce 100644
--- a/dev-python/pysolr/Manifest
+++ b/dev-python/pysolr/Manifest
@@ -1 +1,2 @@
DIST pysolr-3.3.2.tar.gz 14193 SHA256 eea7b2705b4a24ea658136c55ae5c8c30bb661075600fc64d22e57e73951aa96 SHA512 7252efc42987bdf999d122404e63e6410d2efe7b1a49d378c8ad16c9171d8f26cd5ecd891a8a9daa205333b914ec4f95af105fe1bee25312aa05bb884811aebb WHIRLPOOL b4de2ea699f3acffe84cc6e46a979f01f0a5cf7c8731bad941f6f7f76e8ff41d03d436af7829a07ba05ebee850e5d202f6efd0e195f9e639196289da5d267227
+DIST pysolr-3.5.0.tar.gz 17640 SHA256 afb9e379d3689a12f83ac8cd857785075bad909cd876e81a26dccdada469b3be SHA512 8c5e4e34890b63e301e757e46c19dd82d7e6df03665ece96c233a1a5af0025e54d3db653721af0a2615157b926b7c8a9d5af3c758d740f99f3b2489b96320690 WHIRLPOOL 2ab862044b8ea91ea74ee08153c413927c105e60ec3136f26e3f7ca87fc5aa1c03c4569eafd7f6b0c42bdb69a697a521e267d1c8ab83c1b49df0e60d3eba6c86
diff --git a/dev-python/pysolr/pysolr-3.5.0.ebuild b/dev-python/pysolr/pysolr-3.5.0.ebuild
new file mode 100644
index 000000000000..02215372aaf7
--- /dev/null
+++ b/dev-python/pysolr/pysolr-3.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight python wrapper for Apache Solr"
+HOMEPAGE="https://pypi.python.org/pypi/pysolr/ https://github.com/toastdriven/pysolr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"