summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-08-22 00:56:27 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-08-22 01:09:25 +0200
commit773c13def4f8a458b2fd65222c5c252ac77f5da8 (patch)
tree295d6105f558757f479be1d38690ebde82898007 /dev-python
parentsys-fs/e2fsprogs: bump to v1.44.4 (diff)
downloadgentoo-773c13def4f8a458b2fd65222c5c252ac77f5da8.tar.gz
gentoo-773c13def4f8a458b2fd65222c5c252ac77f5da8.tar.bz2
gentoo-773c13def4f8a458b2fd65222c5c252ac77f5da8.zip
dev-python/colorama: add Python 3.7, tests
This requires using the GitHub tarball instead of PyPI's. Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/colorama/Manifest1
-rw-r--r--dev-python/colorama/colorama-0.3.9-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/colorama/Manifest b/dev-python/colorama/Manifest
index 7088a8e4e7ba..b28409a2b9f1 100644
--- a/dev-python/colorama/Manifest
+++ b/dev-python/colorama/Manifest
@@ -1,2 +1,3 @@
DIST colorama-0.3.3.tar.gz 22765 BLAKE2B 3dc399c3a073fba825e85c667c6af1a5b8777dc65ff5ae8fcdb7fe6d20a3193ff391a28140ee90316893250a61b77bd8efca9df03ae88c7f20c24545c8f30e4c SHA512 8e6177ea60ab8f1267ce982f23803a9d2eb0c4550d7eac4776416d62a99d1ce03254fc64cc959ca95e2409ceeff081d4d19359c383e969dfb921b44c56914495
+DIST colorama-0.3.9.github.tar.gz 122180 BLAKE2B 0ef1b2876a8d790e434548649d34bc38940eb48883080168d11cca79fc17c2cab258831ac2660be69eca28000864d617cb4a448558f8e473bca22cce090a8e03 SHA512 7bf6ec19181431d91f5c7a5334d01f9934d4555004e985f82ad74fc325c465339a4c3fdf017af6e0682e0b22e2bf78938cd222b670e5035f305d2d616b03d1d1
DIST colorama-0.3.9.tar.gz 25053 BLAKE2B f633a188d032c41d0b6de60540ca1774dd8f3e8fe2e558333baf09855db30fa7a7ade5944ff12e4ca1a3685930d10a02009162733666d711ad25a16ee96ace55 SHA512 248e3d3d1f95cb85baf55ef4d705508213b81edfb04b39fe9a7bc9c7ac564986726ab6e9d9f73d64ee02e1c9b86d4c6bba40543590dbd170180a37d69e07b627
diff --git a/dev-python/colorama/colorama-0.3.9-r1.ebuild b/dev-python/colorama/colorama-0.3.9-r1.ebuild
new file mode 100644
index 000000000000..05ea77f60e5f
--- /dev/null
+++ b/dev-python/colorama/colorama-0.3.9-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.org/project/colorama/
+ https://github.com/tartley/colorama
+"
+# https://github.com/tartley/colorama/pull/183
+SRC_URI="https://github.com/tartley/${PN}/archive/${PV}.tar.gz -> ${P}.github.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+python_test() {
+ # Skip two tests which seem to fail when stdout isn't a TTY
+ # https://github.com/tartley/colorama/issues/169
+ pytest -vv -k "not (testInitDoesntWrapOnEmulatedWindows \
+ or testInitDoesntWrapOnNonWindows)" \
+ || die "tests failed with ${EPYTHON}"
+}