summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-21 13:38:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-21 14:39:33 +0200
commita79b9ddd039648f50a2fce77218bc37f95251973 (patch)
tree9e9da2c09165f1b22b1ddbe8286a1907cb40cf29 /dev-python/xcffib
parentdev-python/pytest-freezegun: Bump to 0.4.2 (diff)
downloadgentoo-a79b9ddd039648f50a2fce77218bc37f95251973.tar.gz
gentoo-a79b9ddd039648f50a2fce77218bc37f95251973.tar.bz2
gentoo-a79b9ddd039648f50a2fce77218bc37f95251973.zip
dev-python/xcffib: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xcffib')
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/files/xcffib-0.10.0-testing.patch23
-rw-r--r--dev-python/xcffib/xcffib-0.10.0.ebuild40
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index e2b88c48bce5..1f7a9aa59aa7 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1 +1,2 @@
+DIST xcffib-0.10.0.tar.gz 84641 BLAKE2B 06f0ccd420437e11e1aff8d6c7111185d9ff8ed08e40ccab13fed2431134671c55722e0a7a72773cde8518a6c3d4ef14de1a99f0c61d85e9a8feff41545c626a SHA512 2d0a6e7c6b8b43e82f1621a8408ba951e67239099bc947a6da62a6735ff6584ba422e55659969093d51f6de53fe4a400b330def1e6b9eb2c698d82ffc9ff81e4
DIST xcffib-0.9.0.tar.gz 83063 BLAKE2B 898fbce1ff503a9ad64a4c34778e0b5ffef531cf2ad04327f1890c87adb5f91287465e39a981a3c5a628c048b8acbb38bac3b0b76a58c3bbe45ab34c9a5eacf5 SHA512 e5891f080fcf1df596c37bb64a70e0de4a41d83b4675dac3b1c128656ab1b09d865e3ab0bfe0e5cc523e89a75dc6127dfc455ab66ca543ba6eeae9ee5bdae168
diff --git a/dev-python/xcffib/files/xcffib-0.10.0-testing.patch b/dev-python/xcffib/files/xcffib-0.10.0-testing.patch
new file mode 100644
index 000000000000..7c075ae9811c
--- /dev/null
+++ b/dev-python/xcffib/files/xcffib-0.10.0-testing.patch
@@ -0,0 +1,23 @@
+diff --git a/xcffib/testing.py b/xcffib/testing.py
+index ef0268a..0662fcf 100644
+--- a/xcffib/testing.py
++++ b/xcffib/testing.py
+@@ -31,11 +31,14 @@ def lock_path(display):
+ def find_display():
+ display = 10
+ while True:
+- f = open(lock_path(display), "w+")
+ try:
+- fcntl.flock(f.fileno(), fcntl.LOCK_EX | fcntl.LOCK_NB)
+- except OSError:
+- f.close()
++ f = open(lock_path(display), "w+")
++ try:
++ fcntl.flock(f.fileno(), fcntl.LOCK_EX | fcntl.LOCK_NB)
++ except:
++ f.close()
++ raise
++ except OSError:
+ display += 1
+ continue
+ return display, f
diff --git a/dev-python/xcffib/xcffib-0.10.0.ebuild b/dev-python/xcffib/xcffib-0.10.0.ebuild
new file mode 100644
index 000000000000..a3f9db7dd1b8
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/six[${PYTHON_USEDEP}]
+ ${DEPEND}"
+BDEPEND="
+ test? (
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+distutils_enable_tests nose
+
+PATCHES=(
+ "${FILESDIR}"/${P}-testing.patch
+)
+
+src_prepare() {
+ touch test/__init__.py || die
+ distutils-r1_src_prepare
+}