summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 14:00:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 14:03:06 +0200
commit65c57cc3976f77cc336698a1410c1f1f24e68704 (patch)
tree63e04741a39d91cd192fb9b4404bde4f980cb97c /dev-python/wsgiproxy2
parentdev-python/wsgiproxy2: Stabilize 0.4.6 ALLARCHES (diff)
downloadgentoo-65c57cc3976f77cc336698a1410c1f1f24e68704.tar.gz
gentoo-65c57cc3976f77cc336698a1410c1f1f24e68704.tar.bz2
gentoo-65c57cc3976f77cc336698a1410c1f1f24e68704.zip
dev-python/wsgiproxy2: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsgiproxy2')
-rw-r--r--dev-python/wsgiproxy2/Manifest2
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild50
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.4-r1.ebuild50
3 files changed, 0 insertions, 102 deletions
diff --git a/dev-python/wsgiproxy2/Manifest b/dev-python/wsgiproxy2/Manifest
index 2274a532485d..f0474ae6741d 100644
--- a/dev-python/wsgiproxy2/Manifest
+++ b/dev-python/wsgiproxy2/Manifest
@@ -1,3 +1 @@
-DIST WSGIProxy2-0.4.2.zip 18817 BLAKE2B 90334926b726024c1a16b066d11cfe579ad80515861811766753aa772fa97e521466bce0a08c028a965e51ec40b977feb1f4b59aa6c023ca6a431deb63668ed5 SHA512 3dd750263485ceb644373d8ea9692c9a46126a1ed7cd640feba7d42b0fe618e290dcae2f76dc83be77de34211ac473f5a1496a8309e3fcc64982e9642af786fb
-DIST WSGIProxy2-0.4.4.tar.gz 16475 BLAKE2B 8cc91e8364204a03fb8f80abb926e69112c2224b595c695d25e2fa54553fe9c82e3420f68b58f266d04450dd49a6dbf9257c190da8645dfeee976ae101fc708b SHA512 6ae9fca65fe80f52924f42b26b447631e8c278f517ababc23d26e5f8598d6d9b7975197ec74faf64f2e051824366ac14c5db5727a014a187c70a1b4604105b42
DIST WSGIProxy2-0.4.6.tar.gz 16481 BLAKE2B c33dc34d430da795e8144e06e1d6f100cce7d0155295c2d3038567a048647a4f008dbc0156fd4234ce069b3f4ec01af0e42b174dd68c92c9cb3ff4e13be83f8a SHA512 c60d794c0c8b383bf1857ec325d6d0b4fce9c4aec4a06cbf9d7549b609633e491e137342b7bbaf4eec12462eabba63096328c8517b0685e241d1baecd5827cad
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild
deleted file mode 100644
index 765567798ea7..000000000000
--- a/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-MY_PN="WSGIProxy2"
-
-DESCRIPTION="HTTP proxying tools for WSGI apps"
-HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc64 s390 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
- dev-python/socketpool[${PYTHON_USEDEP}]
- dev-python/restkit[$(python_gen_usedep python2_7)] )"
-# Tests needing restkit are skipped under py3
-# Testing also revealed the suite needs latest webtest
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- cd docs || die
- sphinx-build -b html -d _build/doctrees . _build/html
- fi
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.4-r1.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.4-r1.ebuild
deleted file mode 100644
index 7ea464b9271a..000000000000
--- a/dev-python/wsgiproxy2/wsgiproxy2-0.4.4-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="WSGIProxy2"
-
-DESCRIPTION="HTTP proxying tools for WSGI apps"
-HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
- dev-python/socketpool[${PYTHON_USEDEP}]
- dev-python/restkit[$(python_gen_usedep python2_7)] )"
-# Tests needing restkit are skipped under py3
-# Testing also revealed the suite needs latest webtest
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- cd docs || die
- sphinx-build -b html -d _build/doctrees . _build/html
- fi
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}