summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/weberror
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/weberror')
-rw-r--r--dev-python/weberror/Manifest2
-rw-r--r--dev-python/weberror/metadata.xml8
-rw-r--r--dev-python/weberror/weberror-0.10.3-r1.ebuild35
-rw-r--r--dev-python/weberror/weberror-0.11.ebuild35
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/weberror/Manifest b/dev-python/weberror/Manifest
new file mode 100644
index 000000000000..bee7719f4d77
--- /dev/null
+++ b/dev-python/weberror/Manifest
@@ -0,0 +1,2 @@
+DIST WebError-0.10.3.tar.gz 81126 SHA256 a6cb354ff921aad008336599b5e56622ebbe8c76d86985e22af262e6f7242f3b SHA512 a0540429ca602e56c746887fb481e2ed7f8116318267457ded7cfb2b094bb5090be874c4b13fe369c7dc41ba602dea8af444e97c6825ae33b2976d97cf00defe WHIRLPOOL 6fc0179fc8cc05606ca1c79d88d9cb928cf66b65612fbc0de2308a647c3393ceb457b2ddf70af8054d90e2b5ded41c7a898d5ba5332eb287eecd43a0641cd2e3
+DIST WebError-0.11.tar.gz 91520 SHA256 b9d93480d28439a168098215a499b3789d08fcba3c6d24675d4c1f5e16e196cb SHA512 9e2cb470b1bc92a4d6344e4a5577504cc899184f0a53a9d0714fa00adb30e6b33d8568a26df735f6a71856ff2fba1ec6ed73c7d307a8a308e06e9d5c88813cb4 WHIRLPOOL 1af754a3b1a0346d9a55b5477ea644ab0f05a1a62705c52d232eb6a2418d5dc790183177dfbe3d916eb297c6507e02138bb3d849d1de0e1287bb2aab541a727f
diff --git a/dev-python/weberror/metadata.xml b/dev-python/weberror/metadata.xml
new file mode 100644
index 000000000000..1b97c1c396ce
--- /dev/null
+++ b/dev-python/weberror/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">WebError</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/weberror/weberror-0.10.3-r1.ebuild b/dev-python/weberror/weberror-0.10.3-r1.ebuild
new file mode 100644
index 000000000000..d537b5e859e4
--- /dev/null
+++ b/dev-python/weberror/weberror-0.10.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="WebError"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Web Error handling and exception catching"
+HOMEPAGE="http://pypi.python.org/pypi/WebError"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/paste-1.7.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/tempita[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/webtest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/weberror/weberror-0.11.ebuild b/dev-python/weberror/weberror-0.11.ebuild
new file mode 100644
index 000000000000..34ae811f7a27
--- /dev/null
+++ b/dev-python/weberror/weberror-0.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="WebError"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Web Error handling and exception catching"
+HOMEPAGE="http://pypi.python.org/pypi/WebError"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/paste-1.7.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/tempita[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/webtest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}