summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gmail.com>2021-08-09 11:07:18 +0300
committerMichał Górny <mgorny@gentoo.org>2021-08-09 11:20:01 +0200
commitf28fe386fcdf19be9cf37e3095cdcbe68b33ca61 (patch)
tree61404889a3d51a23548eab4f9d5ed97bd7aa80ed /dev-python/treq
parentdev-python/treq: Add python@ as co-maint. (diff)
downloadgentoo-f28fe386fcdf19be9cf37e3095cdcbe68b33ca61.tar.gz
gentoo-f28fe386fcdf19be9cf37e3095cdcbe68b33ca61.tar.bz2
gentoo-f28fe386fcdf19be9cf37e3095cdcbe68b33ca61.zip
dev-python/treq: enable py3.10, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/treq')
-rw-r--r--dev-python/treq/treq-21.5.0.ebuild18
1 files changed, 4 insertions, 14 deletions
diff --git a/dev-python/treq/treq-21.5.0.ebuild b/dev-python/treq/treq-21.5.0.ebuild
index b5f62bffd38c..f81142924b6e 100644
--- a/dev-python/treq/treq-21.5.0.ebuild
+++ b/dev-python/treq/treq-21.5.0.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -47,17 +47,7 @@ python_install_all() {
distutils-r1_python_install_all
}
-test_instructions() {
- ewarn "The 'test' USE flag and FEATURE only ensures that the correct"
- ewarn "dependenciess are installed for this package."
- ewarn "Please run eg:"
- ewarn "$ python3.7 /usr/bin/trial treq"
- ewarn "as a user for each of the python versions it is installed to"
- ewarn "to correctly test this package."
-}
-
python_test() {
- # Tests fail when run via emerge
- # they need proper network access
- test_instructions
+ distutils_install_for_testing
+ "${EPYTHON}" trial treq || die "Tests failed with ${EPYTHON}"
}