summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-28 09:13:52 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-28 10:16:27 +0200
commitf9943eb9c2a933e6a0fd6050306d9416f4c33dec (patch)
tree6e348dfaed86ddd047b8b1a82b0df81979a53b22 /dev-python/translate-toolkit
parentapp-portage/gentoopm: Remove old (diff)
downloadgentoo-f9943eb9c2a933e6a0fd6050306d9416f4c33dec.tar.gz
gentoo-f9943eb9c2a933e6a0fd6050306d9416f4c33dec.tar.bz2
gentoo-f9943eb9c2a933e6a0fd6050306d9416f4c33dec.zip
dev-python/translate-toolkit: Bump to 3.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest1
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.3.5.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 50528f668efb..c6cbe51a6a82 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,2 +1,3 @@
DIST translate-toolkit-3.3.3.tar.gz 5903525 BLAKE2B a21c5d89c808615ff2f3f718e732ce5d5591a9d8a997950ae1066655cc3e4382065f75e7a86f8e37bdd0e146283f9bd941ff20479cb1af635f393e0e7f8fc196 SHA512 41964dc26dfbb983b1c2e4cbb0e9d8eb2a035369a94ef872f7703080b5ca0280a9364916a1e1256cd358b263bc72198e767462cc9065b54556fc481d1b85a836
DIST translate-toolkit-3.3.4.tar.gz 6060105 BLAKE2B 01f8e718a4a60d0f4d439be14b30b2e3f040045630d6f6254ad291a2558d59718521bfb79761d20933f7bb1abd2229ccce67fd71ccd54f6e43dffa7e7ecedd8c SHA512 6bfc4387aa600610fa2a9e7e58368924768ddcc8eb2a697ef02c59682e1e1304b7096f48a1e6e38cd47c68c644dff01d35ffc988d378dbf4833b41d1c5432c05
+DIST translate-toolkit-3.3.5.tar.gz 6061630 BLAKE2B 18843344acf8eecf6d1859e1c6d6148046ba3adc56d00413234e1fb755e7cc14f3ffc22d9cc46b249d01ea5d4b73b4edf4d8c6a22ddb882c62183e1f4ce8dd23 SHA512 9e5837e487b7ec703078d6babfeb2fc720c4c4fd2896e5a23839a856d76f6372d5d3c72f5f1e20ee9d130cb2224c5d8a5b9e33e0154484edd0e0ed756ae8429f
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.3.5.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.3.5.ebuild
new file mode 100644
index 000000000000..b209da46f3f0
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.3.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="https://github.com/translate/translate"
+SRC_URI="https://github.com/translate/translate/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND=">=dev-python/six-1.11.0[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}
+ !dev-python/pydiff
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
+ >=dev-python/python-levenshtein-0.12.0[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+BDEPEND+="
+ test? ( dev-python/phply[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-bootstrap-theme
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/translate-toolkit-3.3.0-no-install-docs.patch
+)
+
+python_test() {
+ local deselect=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ --deselect 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ --deselect 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ )
+
+ if ! use ini; then
+ deselect+=(
+ --ignore translate/convert/test_ini2po.py
+ --ignore translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ deselect+=(
+ --ignore translate/storage/test_subtitles.py
+ )
+ fi
+
+ # translate/storage/test_mo.py needs 'pocompile'
+ distutils_install_for_testing
+ epytest "${deselect[@]}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+
+ python_optimize
+}