summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-27 04:20:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-27 05:10:35 +0200
commit6d29e4c7715da1faab5209c274e68d1a9281e7c2 (patch)
tree675c3b7d5198108d255fea2ab5a52b9578d1582e /dev-python/tldextract
parentnet-libs/nodejs: Stabilize 18.16.0 arm, #904237 (diff)
downloadgentoo-6d29e4c7715da1faab5209c274e68d1a9281e7c2.tar.gz
gentoo-6d29e4c7715da1faab5209c274e68d1a9281e7c2.tar.bz2
gentoo-6d29e4c7715da1faab5209c274e68d1a9281e7c2.zip
dev-python/tldextract: Bump to 3.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tldextract')
-rw-r--r--dev-python/tldextract/Manifest1
-rw-r--r--dev-python/tldextract/tldextract-3.4.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/tldextract/Manifest b/dev-python/tldextract/Manifest
index bd5bdeccd7e2..ef943c08079c 100644
--- a/dev-python/tldextract/Manifest
+++ b/dev-python/tldextract/Manifest
@@ -1 +1,2 @@
DIST tldextract-3.4.0.tar.gz 111437 BLAKE2B 94a3a77144fcaddebdf2129cea8fd43e971f0ac9b40029c6c1735ee06f499f4bf48823fc61540d99f71fd62192742c10168ef8f25b534eec9e2a04d3879be63a SHA512 6cd6b079c35af62e4f8da67c687630471d1a57ebfab7d982abe411b03fb6673dd238a1f676de5624d13bd2eb42b91ae0a97708e33579217916d88bca4db218db
+DIST tldextract-3.4.1.tar.gz 104202 BLAKE2B 24e6f5a4af1718fdf3b52b2c12146849033b80fc0ba0320ccf72735fd0e39c36678660a70a203964ebd92acb3911e037b899b1796a941731735fa1e028999cd1 SHA512 6b63ba8f800e1adc836ecee43947fc0ee5198eefe7d3f64a267c7e0a4d18a44c60454ba67636a4b19e00a125f8b37f1f816f782976a9a335e5500a333c8e07aa
diff --git a/dev-python/tldextract/tldextract-3.4.1.ebuild b/dev-python/tldextract/tldextract-3.4.1.ebuild
new file mode 100644
index 000000000000..896936d16d06
--- /dev/null
+++ b/dev-python/tldextract/tldextract-3.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Accurately separate the TLD from the registered domain and subdomains of a URL"
+HOMEPAGE="
+ https://github.com/john-kurkowski/tldextract/
+ https://pypi.org/project/tldextract/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-file[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest