summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/tdaemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/tdaemon')
-rw-r--r--dev-python/tdaemon/Manifest1
-rw-r--r--dev-python/tdaemon/metadata.xml11
-rw-r--r--dev-python/tdaemon/tdaemon-0.1.6.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/tdaemon/Manifest b/dev-python/tdaemon/Manifest
new file mode 100644
index 000000000000..c6afc92ea5e6
--- /dev/null
+++ b/dev-python/tdaemon/Manifest
@@ -0,0 +1 @@
+DIST tdaemon-0.1.6.tar.gz 37206 SHA256 9f2ed243f1d4b20bd54da505912c82c65dd3cbaf3e247d17a15f42dd0a3e5d56 SHA512 b0d49cc3ca4acef8bdb38cde4c1d17cd973215a8cedeb5716831ea129e8fc69a0c890eda7740a35a238ce39272278d8a80c3e4fc26099317bd7b86e80b36def5 WHIRLPOOL 39f72d4e381cf836b1d288a4d2807383e095241268b52cc8450c2d118182ee3befda5f9b5138f0f3ed9e3998ef4b1718c1ac02c86529df44bd3c17f8a3771dc4
diff --git a/dev-python/tdaemon/metadata.xml b/dev-python/tdaemon/metadata.xml
new file mode 100644
index 000000000000..75c15f485233
--- /dev/null
+++ b/dev-python/tdaemon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <use>
+ <flag name="coverage">Enable code coverage support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">tampakrap/tdaemon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tdaemon/tdaemon-0.1.6.ebuild b/dev-python/tdaemon/tdaemon-0.1.6.ebuild
new file mode 100644
index 000000000000..a8a3d2876d74
--- /dev/null
+++ b/dev-python/tdaemon/tdaemon-0.1.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Test Daemon"
+HOMEPAGE="http://github.com/brunobord/tdaemon"
+SRC_URI="https://github.com/tampakrap/tdaemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="coverage"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/notify-python[${PYTHON_USEDEP}]
+ coverage? ( dev-python/coverage[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ if "${PYTHON}" -m test; then
+ einfo "Test passed under ${EPYTHON}"
+ else
+ die "Test failed under ${EPYTHON}"
+ fi
+}