summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-14 11:46:37 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-14 12:20:00 +0200
commitc534153630f733a6962380de1eeedaa402ceb0e4 (patch)
tree2616474d3c10d767105ffd57886ca2edb8ebec99 /dev-python/sphinx-notfound-page
parentdev-python/autopep8: Sync live ebuild (diff)
downloadgentoo-c534153630f733a6962380de1eeedaa402ceb0e4.tar.gz
gentoo-c534153630f733a6962380de1eeedaa402ceb0e4.tar.bz2
gentoo-c534153630f733a6962380de1eeedaa402ceb0e4.zip
dev-python/sphinx-notfound-page: v0.5, Py3.8+3.9, tests, fix deps
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest1
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index 9c50f6bfa67a..5225d10cfeb9 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1 +1,2 @@
DIST sphinx-notfound-page-0.4.tar.gz 5685 BLAKE2B 0bfc6cf98e0731a5cc95f1802dad1e7297ed764a626831b970d75d82ec0f7d6edb45c404851ea13bf38decc39aabf0e3dd6b136714a591e8ab595f11e23e67cd SHA512 56e867e6954f26da498b77e8fa43e8d62961ab33ee9c16d2084745dd54a998df51c7d882a47560196135d2fb4d473f7305ef19b31373bc205f8eaf0d3d4946f0
+DIST sphinx-notfound-page-0.5.tar.gz 47806 BLAKE2B 4715bed7509970f9198a0c666a568ca403157ad0704d0e1d17d222e6e8dc7adefab3922a4b79e056d20034463d5f034cba8c7b65248569a46866a964abec7e70 SHA512 a48cf4bcc755687c9e02482727ab2c28abe314118cef775e6b5625e2db67e4040745740c3c9fd88206bf050f1621ef20ffb0262ec614c11497ef030f9fb675a3
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild
new file mode 100644
index 000000000000..6fef53b3f911
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded."
+HOMEPAGE="https://sphinx-notfound-page.readthedocs.io/"
+# PyPI tarballs lack tests
+# https://github.com/readthedocs/sphinx-notfound-page/pull/110
+SRC_URI="https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest