summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-04 14:30:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-04 14:49:41 +0200
commit9147f8fcd2ed4d49feefd93bd2de9f26cf6d92b7 (patch)
treeef176e43fcba3cb42123fac01f0e27e26767451a /dev-python/sphinx-celery/sphinx-celery-2.0.0-r3.ebuild
parentdev-vcs/hg-git + deps: marked ~arm64-macos (diff)
downloadgentoo-9147f8fcd2ed4d49feefd93bd2de9f26cf6d92b7.tar.gz
gentoo-9147f8fcd2ed4d49feefd93bd2de9f26cf6d92b7.tar.bz2
gentoo-9147f8fcd2ed4d49feefd93bd2de9f26cf6d92b7.zip
dev-python/sphinx-celery: Add a missing RDEP on dev-python/six
Closes: https://bugs.gentoo.org/907824 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-celery/sphinx-celery-2.0.0-r3.ebuild')
-rw-r--r--dev-python/sphinx-celery/sphinx-celery-2.0.0-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sphinx-celery/sphinx-celery-2.0.0-r3.ebuild b/dev-python/sphinx-celery/sphinx-celery-2.0.0-r3.ebuild
new file mode 100644
index 000000000000..c7091b89ec15
--- /dev/null
+++ b/dev-python/sphinx-celery/sphinx-celery-2.0.0-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Celery Sphinx Theme and Utilities"
+HOMEPAGE="
+ https://github.com/celery/sphinx_celery/
+ https://pypi.org/project/sphinx-celery/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2.0.0[${PYTHON_USEDEP}]
+"