summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-16 10:08:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-16 10:08:48 +0200
commited685754d85177ff7f041aaa3d00326d163ea8db (patch)
treee9f100fe1688b07c12d5e2dcdb264fd9b27774c5 /dev-python/reflink
parentdev-python/ratelimit: Remove old (diff)
downloadgentoo-ed685754d85177ff7f041aaa3d00326d163ea8db.tar.gz
gentoo-ed685754d85177ff7f041aaa3d00326d163ea8db.tar.bz2
gentoo-ed685754d85177ff7f041aaa3d00326d163ea8db.zip
dev-python/reflink: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reflink')
-rw-r--r--dev-python/reflink/reflink-0.2.1-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/reflink/reflink-0.2.1-r1.ebuild b/dev-python/reflink/reflink-0.2.1-r1.ebuild
deleted file mode 100644
index 6319755c9b2d..000000000000
--- a/dev-python/reflink/reflink-0.2.1-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper around the reflink system calls"
-HOMEPAGE="https://gitlab.com/rubdos/pyreflink"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="${RDEPEND}
- test? ( sys-fs/btrfs-progs )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e 's|'\''pytest-runner'\'',\?||' -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local notestmsg="Tests need FEATURES='-usersandbox -userpriv -sandbox'"
- if [[ ${EUID} != 0 ]]; then
- ewarn "${notestmsg}"
- elif
- has sandbox ${FEATURES}; then
- ewarn "${notestmsg}"
- else
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- # module import will fail with any other directory structure
- cp -rv "${S}"/tests ./ || die
- pytest -vv || die "Tests fail with ${EPYTHON}"
- popd >/dev/null || die
- fi
-}