summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 11:20:09 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 11:20:09 +0100
commit32678dc56e233f36bcb080c5174e3a5a0312bb66 (patch)
tree30f861bc4c0311770641f0d65158245fb7d50994 /dev-python/qdarkstyle
parentdev-python/tikzplotlib: cleanup old (diff)
downloadgentoo-32678dc56e233f36bcb080c5174e3a5a0312bb66.tar.gz
gentoo-32678dc56e233f36bcb080c5174e3a5a0312bb66.tar.bz2
gentoo-32678dc56e233f36bcb080c5174e3a5a0312bb66.zip
dev-python/qdarkstyle: add version 3.0.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/qdarkstyle')
-rw-r--r--dev-python/qdarkstyle/Manifest1
-rw-r--r--dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/qdarkstyle/Manifest b/dev-python/qdarkstyle/Manifest
index c20ff0ee5356..495635fc5ddb 100644
--- a/dev-python/qdarkstyle/Manifest
+++ b/dev-python/qdarkstyle/Manifest
@@ -1,2 +1,3 @@
+DIST QDarkStyle-3.0.3.tar.gz 431182 BLAKE2B 3c9406aca5d01c3682123e044d2e5417b300b724c6366a411a00211b482582b26c687128f6c32e7a95a29fb70c3a322fd525483c48120e5671ddff713e4e0035 SHA512 2c44a4469971b127f7fb8c9a5bce452c98653aaf29dcdb7e0df2da7557d6730d64ebf6a649f8516fb13a2d4e77d0fdadc293457d94406d8e7491be3fd52a9313
DIST qdarkstyle-2.8.1.tar.gz 7883937 BLAKE2B fd5a35467c6c47e9eb135d4a119b3f382bfe20b9b0ac2d407fef7113e5ce4d914f3d8e462d26a71b8f1494f42b71a4f8819b0eb2c6579d87ca9dd497d09d39d7 SHA512 10c3f834b1ea50f665c2ce3fde16533c7dfc62c2d055afcc7d2434c09d14fb9a6181b73ce12d3af72897b9d26b41db81cc76e7c7cb6112eef097cd86630b6532
DIST qdarkstyle-3.0.2.tar.gz 8330772 BLAKE2B c64524e2ecc23b714d6f5df6cea007846c6a9b1d5805d12e23c53e27c0411900730c656583bb5446bc343018e4fb1e110994c646e277ee0f3a3a7553df77f3ca SHA512 ef4ffc82fe3b72d89deb5dc98fc7319dbd6dc0bae530bdf612477c44934f587c497f8a9ec9d060fc8fcafdc918447f4dbbab20225f1e5cbf2146bcde83d0ce20
diff --git a/dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild b/dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild
new file mode 100644
index 000000000000..25c68c9ea48f
--- /dev/null
+++ b/dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+MY_PN="QDarkStyle"
+
+DESCRIPTION="A dark style sheet for QtWidgets application"
+HOMEPAGE="https://github.com/ColinDuquesnoy/QDarkStyleSheet"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# TODO: Figure out how to get this to work
+# Please pass a palette class in order to create its qrc file
+# This appears to be fundamentally broken: test calls create_qss() without
+# argument and that function does sys.exit(1) if the argument is None.
+RESTRICT="test"
+
+RDEPEND=">=dev-python/QtPy-1.7[gui,${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/qtsass[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-1.7[gui,testlib,${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Retrieve detailed system information and report bugs upstream" dev-python/helpdev
+ optfeature "qdarkstyle.utils" dev-python/qtsass dev-python/watchdog
+}