summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 19:37:15 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 20:32:37 +0200
commitf8af2c549248d34b083d422d2723be1c2aa5d020 (patch)
treefa3e5cfdb0e889b91cf1012a25e42a1410d6a551 /dev-python/pytest-runner
parentsys-kernel/hardened-sources: version bump to 4.5.7-r1 (diff)
downloadgentoo-f8af2c549248d34b083d422d2723be1c2aa5d020.tar.gz
gentoo-f8af2c549248d34b083d422d2723be1c2aa5d020.tar.bz2
gentoo-f8af2c549248d34b083d422d2723be1c2aa5d020.zip
dev-python/pytest-runner: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/pytest-runner')
-rw-r--r--dev-python/pytest-runner/Manifest1
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.8.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-runner/Manifest b/dev-python/pytest-runner/Manifest
index f548becf0d71..bfe3761cc45d 100644
--- a/dev-python/pytest-runner/Manifest
+++ b/dev-python/pytest-runner/Manifest
@@ -1 +1,2 @@
DIST pytest-runner-2.6.2.tar.gz 6379 SHA256 e775a40ee4a3a1d45018b199c44cc20bbe7f3df2dc8882f61465bb4141c78cdb SHA512 6a993e8729d5e203986f2526d46e96b7ac19e65fc26493a55a98e858304ecde0c47576476864a0ee1817ea1a7b02cfda952fc03f79b84fff249021f140f3d00d WHIRLPOOL 968a38864b58d35d4c9fb0fa2855bae9f87bcb68936b5f129c5bc67b2c751e51bf5f9e5f54d27f36ccd6e89df7d4f8c4a6556de408cc8287f52725e1eb73fef5
+DIST pytest-runner-2.8.tar.gz 8535 SHA256 1ec44deddaa551f85fd563c40a4c483a2609aca1f284a95399566a74d0680d5c SHA512 bdbd71dc4713dca2b00fa63e8414dab0611af460c25746d5377881024c23e2c8a6f1374ab9c94fa33dae1ac2f0b7ba10f747287a3cbaeb5a44ff1dd4542e122e WHIRLPOOL 541421d6f2a8490c58fb1c33c7227ab685f9031626c8007f867d2bbc81c8913a3bcc709f34707eca2d239706eb86b090bd49024b8ee5111a4d5e84f9a292a2f0
diff --git a/dev-python/pytest-runner/pytest-runner-2.8.ebuild b/dev-python/pytest-runner/pytest-runner-2.8.ebuild
new file mode 100644
index 000000000000..a39f93317fc6
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-2.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests during installation of setup.py files"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-runner https://bitbucket.org/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ "
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+# Test not included
+RESTRICT="test"
+
+python_compile_all() {
+ # The build by rst2html.py makes non fatal errors building index.rst
+ if use doc; then
+ rst2html.py docs/history.rst > docs/history.html
+ rst2html.py docs/index.rst > docs/index.html
+ fi
+}
+
+python_test() {
+ esetup.py pytest
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}