summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-24 09:29:28 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-24 09:42:41 +0100
commita5b4293a02bf167ed81306f210fbcdab6e7a5378 (patch)
tree193302b376c6b6c1baab751158ca033b3364ceee /dev-python/pygit2
parentdev-ruby/rspec: add ruby25 (diff)
downloadgentoo-a5b4293a02bf167ed81306f210fbcdab6e7a5378.tar.gz
gentoo-a5b4293a02bf167ed81306f210fbcdab6e7a5378.tar.bz2
gentoo-a5b4293a02bf167ed81306f210fbcdab6e7a5378.zip
dev-python/pygit2: Bump to 0.26.4
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-0.26.4.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 544d6a639167..bc31ca130778 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1 +1,2 @@
DIST pygit2-0.26.3.tar.gz 462080 BLAKE2B b3c4b9b8a6aeba22a70a8d2ef1393dace3a065a3625ee3574058e333bca4ba1d60223939f412eecf5ae9d93a81fb81c4a536af46aa047c2c82a48bd81afe4cf9 SHA512 6f727686221d4e8c348f836b7ad278b48a4b971a121b9953c2cf7163bf093936d838aaf83e9edb8628757624ab27e8345a2fb29eb1a79a30e06c0ab0a77e4cc6
+DIST pygit2-0.26.4.tar.gz 477318 BLAKE2B d17ef799ff3eab3629194fe0fe90dcc335e40509c13f53bc8f8e0b01e93dc838ca474a5e4ef44c9be2eac7d08e98c735820e936cbbcb7f398f76f9732954bc69 SHA512 e459e47bfa8137421625633a731d49882d95a52d4f2d672f2c8efe7cd6cca4b33335ee77777a353b309df4917d9b29b30c1f9a96b7e226e3e7fe0cd34bbefce6
diff --git a/dev-python/pygit2/pygit2-0.26.4.ebuild b/dev-python/pygit2/pygit2-0.26.4.ebuild
new file mode 100644
index 000000000000..64a6fc92b351
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.26.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 eapi7-ver
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.python.org/pypi/pygit2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(ver_cut 1-2)*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test --args='-v'
+}