summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-03 15:08:57 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-03 15:09:26 +0200
commit1cf2906a2d3458bf1077ff369e0ae79b8f2fade7 (patch)
treecd246824c2bbcfdf83c847a42c278a884209489a /dev-python/pyftpdlib
parentdev-python/pillow: fix dependencies (diff)
downloadgentoo-1cf2906a2d3458bf1077ff369e0ae79b8f2fade7.tar.gz
gentoo-1cf2906a2d3458bf1077ff369e0ae79b8f2fade7.tar.bz2
gentoo-1cf2906a2d3458bf1077ff369e0ae79b8f2fade7.zip
dev-python/pyftpdlib: skip another failing test
Closes: https://bugs.gentoo.org/659786 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
index a5c7dac5aee0..a956577edbe4 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
@@ -48,15 +48,24 @@ python_compile_all() {
}
python_test() {
- # Skip tests which sometimes fail:
- # https://github.com/giampaolo/pyftpdlib/issues/470
- # https://github.com/giampaolo/pyftpdlib/issues/471
- py.test --ignore ${PN}/test/test_misc.py -k \
- "not (test_idle_data_timeout2 or test_on_incomplete_file_received)" \
- || die "Tests failed with ${EPYTHON}"
# These tests fail when passing additional options to py.test
# so we need to run them separately
py.test ${PN}/test/test_misc.py || die "Tests failed with ${EPYTHON}"
+ # Some of these tests tend to fail
+ local skipped_tests=(
+ # https://github.com/giampaolo/pyftpdlib/issues/470
+ # https://bugs.gentoo.org/659108
+ test_idle_data_timeout2
+ # https://github.com/giampaolo/pyftpdlib/issues/471
+ # https://bugs.gentoo.org/636410
+ test_on_incomplete_file_received
+ # https://github.com/giampaolo/pyftpdlib/issues/466
+ # https://bugs.gentoo.org/659786
+ test_nlst
+ )
+ skipped_tests=${skipped_tests[@]/%/ or}
+ py.test --ignore ${PN}/test/test_misc.py -k "not (${skipped_tests% or})" \
+ || die "Tests failed with ${EPYTHON}"
}
python_install_all() {