summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-20 11:46:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-20 11:46:41 +0200
commit2400b9dc6406306f7bc539ab09635ea2d968912c (patch)
treed9ca68bb14bf3a62873c01d3221fcce263847dd9 /dev-python/pycparser
parentdev-python/pytest-jupyter: Remove old (diff)
downloadgentoo-2400b9dc6406306f7bc539ab09635ea2d968912c.tar.gz
gentoo-2400b9dc6406306f7bc539ab09635ea2d968912c.tar.bz2
gentoo-2400b9dc6406306f7bc539ab09635ea2d968912c.zip
dev-python/pycparser: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/Manifest1
-rw-r--r--dev-python/pycparser/files/pycparser-2.21-lextab-cache.patch66
-rw-r--r--dev-python/pycparser/pycparser-2.21-r2.ebuild74
3 files changed, 0 insertions, 141 deletions
diff --git a/dev-python/pycparser/Manifest b/dev-python/pycparser/Manifest
index 0ea33f798aa9..92399af68de9 100644
--- a/dev-python/pycparser/Manifest
+++ b/dev-python/pycparser/Manifest
@@ -1,2 +1 @@
-DIST pycparser-2.21.tar.gz 170877 BLAKE2B ae6bf42dfc552bf1e3bfb5430cdb0c15b5e011ec53cbd03e0e2507c08a1a78690cefce2de134bd984caccc5dbde90661cb4c18df5c289217967213aac4d52404 SHA512 e61fbdde484d1cf74d4b27bdde40cf2da4b7028ca8ecd37c83d77473dab707d457321aecaf97da3b114c1d58a4eb200290b76f9c958044b57e5fed949895b5f0
DIST pycparser-2.22.tar.gz 172736 BLAKE2B a080df68cf114c355949b2911a80e89ed02a64b8d1d03e3c5807222249e5dfd2491f691962885dbadcdaf323b55a05c5597319ac082dcf6c67a9ac952be9a7e2 SHA512 c9a81c78d87162f71281a32a076b279f4f7f2e17253fe14c89c6db5f9b3554a6563ff700c385549a8b51ef8832f99f7bb4ac07f22754c7c475dd91feeb0cf87f
diff --git a/dev-python/pycparser/files/pycparser-2.21-lextab-cache.patch b/dev-python/pycparser/files/pycparser-2.21-lextab-cache.patch
deleted file mode 100644
index d24999e7273a..000000000000
--- a/dev-python/pycparser/files/pycparser-2.21-lextab-cache.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From 35a279ecb9af41a6f95ddbc6a0f1beaa2472d165 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 26 Feb 2023 01:04:34 +0100
-Subject: [PATCH] _build_tables: Invalidate cache before importing generated
- modules (#494)
-
-Make sure to invalidate finder caches before trying to import generated
-modules. This is necessary according to the Python documentation:
-https://docs.python.org/3/library/importlib.html#importlib.invalidate_caches
-
-This fixes a hard-to-reproduce bug that Python would be unable to find
-just-generated `lextab.py` if mtime of the current directory did not
-change from the moment the script was started. This could
-e.g. be the case if one has second-precision timestamps and removes
-the generated file just before starting the build, e.g.:
-
- $ rm pycparser/lextab.py; python -m build -nw
-
-It could also be reproduced easier by doing something like:
-
- $ cd pycparser
- $ touch .; python -B _build_tables.py
- Traceback (most recent call last):
- File "/var/tmp/pycparser/pycparser/_build_tables.py", line 38, in <module>
- import lextab
- ModuleNotFoundError: No module named 'lextab'
-
-This is because the first command (`rm` or `touch`) updates the mtime
-of the directory to the current time. If the script is run fast enough,
-it manages to scan the directory and then write the new `lextab.py`
-within the same second. As a result, mtime of the directory after
-writing the new file is the same as when the script was started, finder
-does not invalidate the cache and assumes that `lextab.py` does not
-exist since it did not exist when the directory was scanned earlier.
-
-This potentially fixes #493.
-
-It was originally reported on https://bugs.gentoo.org/701878.
-Thanks to Gary E. Miller for patience in reproducing the problem
-and proxy-debugging it for me, as well as testing the final patch before
-submission.
----
- pycparser/_build_tables.py | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/pycparser/_build_tables.py b/pycparser/_build_tables.py
-index 958381ad..4f371079 100644
---- a/pycparser/_build_tables.py
-+++ b/pycparser/_build_tables.py
-@@ -13,6 +13,7 @@
- # Insert '.' and '..' as first entries to the search path for modules.
- # Restricted environments like embeddable python do not include the
- # current working directory on startup.
-+import importlib
- import sys
- sys.path[0:0] = ['.', '..']
-
-@@ -32,6 +33,8 @@
-
- # Load to compile into .pyc
- #
-+importlib.invalidate_caches()
-+
- import lextab
- import yacctab
- import c_ast
diff --git a/dev-python/pycparser/pycparser-2.21-r2.ebuild b/dev-python/pycparser/pycparser-2.21-r2.ebuild
deleted file mode 100644
index 80938a15df34..000000000000
--- a/dev-python/pycparser/pycparser-2.21-r2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="C parser and AST generator written in Python"
-HOMEPAGE="
- https://github.com/eliben/pycparser/
- https://pypi.org/project/pycparser/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-
-RDEPEND="
- dev-python/ply:=[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
-"
-
-distutils_enable_tests unittest
-
-python_prepare_all() {
- local PATCHES=(
- # https://github.com/eliben/pycparser/pull/494
- "${FILESDIR}"/${P}-lextab-cache.patch
- )
-
- # remove the original files to guarantee their regen
- rm pycparser/{c_ast,lextab,yacctab}.py || die
-
- # kill sys.path manipulations to force the tests to use built files
- sed -i -e '/sys\.path/d' tests/*.py || die
-
- # Ensure we can find tests in our directory
- sed -i -e 's/from tests.test_util/from test_util/g' tests/test_*.py || die
-
- # unbundle ply
- rm -r pycparser/ply || die
- sed -i -e 's:\(from \)[.]\(ply\b\):\1\2:' pycparser/*.py || die
- sed -i -e "s:'pycparser.ply'::" setup.py || die
-
- ln -s "${S}"/examples tests/examples || die
-
- rm tests/test_examples.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Skip tests if cpp is not in PATH
- type -P cpp >/dev/null || return 0
- # change workdir to avoid '.' import
- cd tests || die
-
- # Ensure that 'cpp' is called with the right arguments
- # Tests don't seem to always pass the include they intend to use.
- mkdir -p "${T}"/bin || die
- cat > "${T}"/bin/cpp <<-EOF || die
- #!${BROOT}/bin/bash
- exec ${BROOT}/usr/bin/cpp -I${S}/utils/fake_libc_include/ \$@
- EOF
- chmod +x "${T}"/bin/cpp || die
-
- PATH="${T}/bin:${PATH}" eunittest
-}