summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ndg-httpsclient
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ndg-httpsclient')
-rw-r--r--dev-python/ndg-httpsclient/Manifest2
-rw-r--r--dev-python/ndg-httpsclient/metadata.xml9
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild24
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild26
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/ndg-httpsclient/Manifest b/dev-python/ndg-httpsclient/Manifest
new file mode 100644
index 000000000000..f40dd41bab3b
--- /dev/null
+++ b/dev-python/ndg-httpsclient/Manifest
@@ -0,0 +1,2 @@
+DIST ndg_httpsclient-0.3.2.tar.gz 21514 SHA256 cc806d43f3e79be40f923d94f542f23a94c6ddbb9a63258b0bf875f325508973 SHA512 0060d1b0f749cc3017f4d5550bf0e7242e035f5f84a914a23219a85ba0dd9185e6edf88c38db16df8dfe05beb267262cc2fed00758c0b4d8b2ee222abe2d642e WHIRLPOOL a7d058939909b5b9ffc8c4f9432d97f4cbb76824b34cc5bf9fd0d32edcf2cee77daad34ad48ad8927c2a3c2a30c960cdc5568131706d15089749f3037b66607d
+DIST ndg_httpsclient-0.4.0.tar.gz 24038 SHA256 e8c155fdebd9c4bcb0810b4ed01ae1987554b1ee034dd7532d7b8fdae38a6274 SHA512 3c0225a20c25cf0f12f03005bb79e738527c0488bb660c1eb3b55c505a0ef503002d37fcffb3d013e5f91101bdd03080a68d5805d6d29b682cc01bdc9f0e4a19 WHIRLPOOL 0c9c0a2cd2e5a0d2b742910129442285e4bdf1278c2590443fa00107066f5561af4249d4f1504720e8a48342ba1d0110fe8480e0adcd41ca999384bf3dc06853
diff --git a/dev-python/ndg-httpsclient/metadata.xml b/dev-python/ndg-httpsclient/metadata.xml
new file mode 100644
index 000000000000..7a46194ed57f
--- /dev/null
+++ b/dev-python/ndg-httpsclient/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">ndg-httpsclient</remote-id>
+ <remote-id type="github">cedadev/ndg_httpsclient</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild
new file mode 100644
index 000000000000..62ce5425a0ea
--- /dev/null
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE="http://ndg-security.ceda.ac.uk/wiki/ndg_httpsclient
+ https://pypi.python.org/pypi/ndg-httpsclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-python/pyopenssl[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/-/_}"
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
new file mode 100644
index 000000000000..01ec815e5018
--- /dev/null
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE="https://github.com/cedadev/ndg_httpsclient/
+ https://pypi.python.org/pypi/ndg-httpsclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-python/pyopenssl[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/-/_}"
+
+# doc build by Makefile in folder documentation is broken