summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-04-26 12:34:35 +0200
committerDavid Seifert <soap@gentoo.org>2020-04-26 12:34:35 +0200
commitb27c0a016041af31d0fe62d5bae305f72ebe41b3 (patch)
tree558345a1f9eceac2974229bf69f5961b83c2ec5e /dev-python/moviepy/moviepy-1.0.1-r1.ebuild
parentdev-python/audioread: Replace virtual/ffmpeg (diff)
downloadgentoo-b27c0a016041af31d0fe62d5bae305f72ebe41b3.tar.gz
gentoo-b27c0a016041af31d0fe62d5bae305f72ebe41b3.tar.bz2
gentoo-b27c0a016041af31d0fe62d5bae305f72ebe41b3.zip
dev-python/moviepy: Replace virtual/ffmpeg
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/moviepy/moviepy-1.0.1-r1.ebuild')
-rw-r--r--dev-python/moviepy/moviepy-1.0.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/moviepy/moviepy-1.0.1-r1.ebuild b/dev-python/moviepy/moviepy-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..7621f8f98664
--- /dev/null
+++ b/dev-python/moviepy/moviepy-1.0.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Video editing with Python"
+HOMEPAGE="http://zulko.github.io/moviepy/"
+SRC_URI="https://github.com/Zulko/moviepy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/imageio[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ media-video/ffmpeg
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest