summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-10 10:06:51 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-10 10:09:06 +0100
commit407fadf662d8db5b7b44bb94fe74f197f3224933 (patch)
treee100f9d2ee6bd48b45b78745da392e7c50409b51 /dev-python/mkdocs
parentdev-python/django: Remove old (diff)
downloadgentoo-407fadf662d8db5b7b44bb94fe74f197f3224933.tar.gz
gentoo-407fadf662d8db5b7b44bb94fe74f197f3224933.tar.bz2
gentoo-407fadf662d8db5b7b44bb94fe74f197f3224933.zip
dev-python/mkdocs: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs')
-rw-r--r--dev-python/mkdocs/Manifest1
-rw-r--r--dev-python/mkdocs/mkdocs-1.4.1.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/mkdocs/Manifest b/dev-python/mkdocs/Manifest
index 3e5893e76caf..c5b90ea6b910 100644
--- a/dev-python/mkdocs/Manifest
+++ b/dev-python/mkdocs/Manifest
@@ -1,2 +1 @@
-DIST mkdocs-1.4.1.gh.tar.gz 4018962 BLAKE2B 68484fa4866eed96ecf91d02e308f08480f3dd0ad261a4b94256585ec604126a59aef37b4d61962ed155ab4beb9be14d09574c9b403403fede14cc25579f9780 SHA512 880ec0e6fbb5cf48b998dd685eeebdb25ff0ed4fa9eef8869679550efad15597cb98d00964c3fe1a86c23c5afe2aeee91d704779b4efa42010ce1a582e02bd28
DIST mkdocs-1.4.2.gh.tar.gz 4018656 BLAKE2B 325e940c72f6a8fe7f353a4ba2f65fc6b123c5be04173e5469d3165d25b3d6bb8983b5c541b0d1376770a8205b54860b756eca1719decdd77e7e4c57477998e4 SHA512 cabdb86a5934672645e29055c04f5c877dd5527df909a606d94f930211cec9f4f29f89137dd413238c07af4108d870dd3b880cba447c55690583cd1b13b179b7
diff --git a/dev-python/mkdocs/mkdocs-1.4.1.ebuild b/dev-python/mkdocs/mkdocs-1.4.1.ebuild
deleted file mode 100644
index 112dd416b8a4..000000000000
--- a/dev-python/mkdocs/mkdocs-1.4.1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=hatchling
-inherit distutils-r1
-
-DESCRIPTION="Project documentation with Markdown"
-HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-
-# https://bugs.gentoo.org/873349
-# Building documentation requires packaging: callouts and mkdocs-autorefs
-#
-# IUSE="doc"
-#
-# BDEPEND="
-# doc? (
-# $(python_gen_any_dep '
-# dev-python/mdx_gh_links[${PYTHON_USEDEP}]
-# dev-python/mkdocs-redirects[${PYTHON_USEDEP}]
-# ')
-# )
-# "
-RDEPEND="
- >=dev-python/Babel-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
- >=dev-python/markdown-3.3.3[${PYTHON_USEDEP}]
- <dev-python/markdown-3.4[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/watchdog-2.0[${PYTHON_USEDEP}]
- >=dev-python/ghp-import-1.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml_env_tag-0.1[${PYTHON_USEDEP}]
- >=dev-python/importlib_metadata-4.3[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.5[${PYTHON_USEDEP}]
- >=dev-python/mergedeep-1.3.4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Tests fails if additional themes are installed
- mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes
- mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes_error
- mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes_warning
-
- # Does not work in emerge env
- mkdocs/tests/config/config_options_tests.py::ListOfPathsTest::test_paths_localized_to_config
-)
-
-python_prepare_all() {
- # livereload has been dropped in this release, this test is a remnant
- rm mkdocs/tests/livereload_tests.py || die
-
- # Does not work in emerge env
- sed -i -e 's/test_paths_localized_to_config/_&/' \
- mkdocs/tests/config/config_options_tests.py
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- default
-# if use doc; then
-# # cannot just do mkdocs build, because that fails if
-# # the package isn't already installed
-# python -m mkdocs build || die "Failed to make docs"
-# # Colliding files found by ecompress:
-# rm site/sitemap.xml.gz || die
-# HTML_DOCS=( "site/." )
-# fi
-}
-
-python_test() {
- epytest mkdocs/tests/*
-}