summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-06 06:47:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-06 07:43:40 +0200
commit6260da1f4e449f120e1f92164c1b29f18f92774b (patch)
treef721b211f2fe9ef143b945f3d02b047014badeaa /dev-python/mdit-py-plugins
parentdev-python/atpublic: Bump to 4.0 (diff)
downloadgentoo-6260da1f4e449f120e1f92164c1b29f18f92774b.tar.gz
gentoo-6260da1f4e449f120e1f92164c1b29f18f92774b.tar.bz2
gentoo-6260da1f4e449f120e1f92164c1b29f18f92774b.zip
dev-python/mdit-py-plugins: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mdit-py-plugins')
-rw-r--r--dev-python/mdit-py-plugins/Manifest1
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.4.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index 7e1d1fd8b2a5..b00cffcaf0ee 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1 +1,2 @@
DIST mdit-py-plugins-0.3.5.gh.tar.gz 59757 BLAKE2B bad78ec811d238bafd83c9d1bbd6e0bcac3b70cd87f52b215966e836d4c2a35715804fa1c7d3671de81713c4e169ad4bb6d9dcdf741f617544772d06f8e3ae56 SHA512 6cb153d8ccff8fa3f94731606ad5dd1c06954d95519ac77b6de477e04b878f84fb059052906bdea5d798be3de49733a909cb553107255a61cde6dd1c6c72d4d2
+DIST mdit-py-plugins-0.4.0.gh.tar.gz 62199 BLAKE2B d8e69022ecceed436cd28202406bd46e786d40d3527f1c2c9311c4c32c59a4806cde9dc386309976c185522dd6286aec2542dabd31e08b8d7322fd02ae07186d SHA512 cdcce7a3819120923b7725daae0bf7a833c4da4487c49ff1a067fecf7d5e8f7a7be2fae03f3b821c766d7d6ebed4a298755ad5edb00adf73300a76a5663d67d6
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.0.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.0.ebuild
new file mode 100644
index 000000000000..e3e5a9d87984
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/markdown-it-py-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest