summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-12 07:13:42 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-12 08:33:07 +0100
commit93e3ab1b1f7f8438129233c0fb26402dd889ad08 (patch)
treea4d8f6f629c5fcca9bf27d15b436d8854001154a /dev-python/marshmallow
parentdev-python/marshmallow: Remove old (diff)
downloadgentoo-93e3ab1b1f7f8438129233c0fb26402dd889ad08.tar.gz
gentoo-93e3ab1b1f7f8438129233c0fb26402dd889ad08.tar.bz2
gentoo-93e3ab1b1f7f8438129233c0fb26402dd889ad08.zip
dev-python/marshmallow: Bump to 3.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.19.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 157e92926ed8..d25169bac89a 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.18.0.gh.tar.gz 181535 BLAKE2B 6c808157038cf33d2906fbf2f4aa8a605adfe8301da56ba8f7df782e2970bae7f5e040aa8c9c9bda134b6e7e13d50a9bec1f8e715e06b8543742e2cd142d099d SHA512 25ee09faf93d5ae25b35089881a644cf409edbca3134ad092ad150b166604151c3474bfcd2ae07d29b066e89e67df643e65d9fece4bbad8b11af07554a0ceaf6
+DIST marshmallow-3.19.0.gh.tar.gz 182305 BLAKE2B 2e37e0dcfcab3fa080745ccf6acbaf0fc71a43edfc9227ebf1d5320c61b0f0b51a0f3ea1d75ab1b213f8464d8ac043365ddadc8d9ab4479e21eed92ce5362b4e SHA512 e908ab33703fed5a9290189aa151dfdb425668bebe89063084f10435d2030927ce001c0d34d504d19998863431ded52a7a551085b11212489495d34aadb3b9e1
diff --git a/dev-python/marshmallow/marshmallow-3.19.0.ebuild b/dev-python/marshmallow/marshmallow-3.19.0.ebuild
new file mode 100644
index 000000000000..f924d3b5509e
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.19.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-0.17[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest