summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 04:26:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 04:26:05 +0200
commit7feb503f6f8dcbbdea3118fa1448825ba7a01980 (patch)
tree827615805d3b6fd6302523f7edb5a1ea5b218d79 /dev-python/markdown2
parentdev-python/markdown: Remove old (diff)
downloadgentoo-7feb503f6f8dcbbdea3118fa1448825ba7a01980.tar.gz
gentoo-7feb503f6f8dcbbdea3118fa1448825ba7a01980.tar.bz2
gentoo-7feb503f6f8dcbbdea3118fa1448825ba7a01980.zip
dev-python/markdown2: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown2')
-rw-r--r--dev-python/markdown2/Manifest1
-rw-r--r--dev-python/markdown2/markdown2-2.5.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
index 8da43ed84ea6..e498b6876786 100644
--- a/dev-python/markdown2/Manifest
+++ b/dev-python/markdown2/Manifest
@@ -1 +1,2 @@
DIST markdown2-2.4.13.tar.gz 130464 BLAKE2B 64a1dd8ecb607495042fbf49cbbee5b383eca0c942816c2ff83565ef1c677f6bc851f8921dfc73d68ef6e6b070ac0a4a372421218231f6655dab5c41a1743aea SHA512 df015b53a87138b55fb6ab28c5b4cc8b1a36867a9a1b0fab962399c467e9847b249bff6a8ad920d56c4b72a02b46ffc536e61fa3168794403602926e65091748
+DIST markdown2-2.5.0.tar.gz 138574 BLAKE2B 989a8c8c528ecc0feb4073f02119ee351f4c4ece2e23f03159d3cb76123838e55a5ece846c7bc66fb37760a171606312c3854726d6abeb3a258223500a139fbe SHA512 1fead06f1f1692908f6be3da8f11a010a541cf0c5e38db6744b84aa9b6e2b45ac7a0b3a06427d5dedf0c5bb5eae4636973e625ffbcf066febeb752965c594579
diff --git a/dev-python/markdown2/markdown2-2.5.0.ebuild b/dev-python/markdown2/markdown2-2.5.0.ebuild
new file mode 100644
index 000000000000..7b18bd75a79e
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python Markdown language reimplementation"
+HOMEPAGE="
+ https://github.com/trentm/python-markdown2/
+ https://pypi.org/project/markdown2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pygments-2.7.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" -m unittest test_markdown2.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}