summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-28 08:46:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-28 10:13:35 +0200
commit187c1148752716d3ddd45dbc788a438d731ee0e8 (patch)
tree1ae83e25a5f743d793178309905f79ee3b0d12ed /dev-python/markdown2
parentdev-python/hatchling: Bump to 0.23.0 (diff)
downloadgentoo-187c1148752716d3ddd45dbc788a438d731ee0e8.tar.gz
gentoo-187c1148752716d3ddd45dbc788a438d731ee0e8.tar.bz2
gentoo-187c1148752716d3ddd45dbc788a438d731ee0e8.zip
dev-python/markdown2: Bump to 2.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown2')
-rw-r--r--dev-python/markdown2/Manifest1
-rw-r--r--dev-python/markdown2/markdown2-2.4.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
index 7d15892592d3..d395bec808b3 100644
--- a/dev-python/markdown2/Manifest
+++ b/dev-python/markdown2/Manifest
@@ -1 +1,2 @@
DIST markdown2-2.4.2.tar.gz 96270 BLAKE2B 63808f2b6e8af25eca047e7b24a7ab7ce7afc35fa10aff57b93952cefae765ae8746300f6e93033be87aa73607249198cdfd4fa6e3b3aed711e80d9dc7a006ab SHA512 8c41617213ae8a2d02a986489756d511ee7e1ae970eef348f68808439feaef099ef935ea0a2c31cb9e9abe39899a24fd981a29b7c90d1f8096ba999506121e60
+DIST markdown2-2.4.3.tar.gz 102973 BLAKE2B 7a856a9d0bd539e3de1e358aa7d4968aca62b67a30dc64a905633040a6a525b2ac1ec0d4cd7d8d4ed9b38e68e5df3f187cf0f56e1816a4ec10efe4e849356580 SHA512 b5eb5cb6ac52878a224aa6b4642ade86593de5340594271940b3ef25809a9e37b9b3cbb04f4fa9880a50a4fee8ed85c1c6d76b19065b0fd703363faf4d812679
diff --git a/dev-python/markdown2/markdown2-2.4.3.ebuild b/dev-python/markdown2/markdown2-2.4.3.ebuild
new file mode 100644
index 000000000000..9bf9f43c0072
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.4.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+HOMEPAGE="
+ https://github.com/trentm/python-markdown2/
+ https://pypi.org/project/markdown2/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" -m unittest test_markdown2.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}