summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-14 08:03:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-14 08:26:48 +0200
commit6b4917caf286eb80c3a808f9802d681b2ed3d92f (patch)
tree86a57635653dbde0021b831cf7b01e9595e93152 /dev-python/jsonpickle
parentdev-python/tox: Bump to 4.8.0 (diff)
downloadgentoo-6b4917caf286eb80c3a808f9802d681b2ed3d92f.tar.gz
gentoo-6b4917caf286eb80c3a808f9802d681b2ed3d92f.tar.bz2
gentoo-6b4917caf286eb80c3a808f9802d681b2ed3d92f.zip
dev-python/jsonpickle: Bump to 3.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/Manifest1
-rw-r--r--dev-python/jsonpickle/jsonpickle-3.0.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
index 0f06523c022f..79ae1543c3fa 100644
--- a/dev-python/jsonpickle/Manifest
+++ b/dev-python/jsonpickle/Manifest
@@ -1 +1,2 @@
DIST jsonpickle-3.0.1.gh.tar.gz 257651 BLAKE2B 4875985085c8303b316b387968ad46bc35672259f8f6799270bff5dee1b4d341bd92e520155d5c5ff644b289ac21275e95911a38165303c07c4634a93e17ae62 SHA512 3190716491c01de1e5ce16cd8fee3163c20831521503803a5282b43c6653756554fa6184de78755f3232ac6c9bc51baccb91305f9ac9462c8e22fc57fbcc52eb
+DIST jsonpickle-3.0.2.gh.tar.gz 258895 BLAKE2B 51af5841fada084c4fdb27d2d9c95ba0a790027d6a67b37bee6cbf9f256ee2778cffa38fd994de728b58c03536a07492335fbe6d4e7eed875561a3264232f81e SHA512 ed2552a68ca05a6e7e01169697c1c46735f99df95d126007ac02c0315b32da45ddbb1265ab53e39e9f4f1b54029a764cb50a05f31d773bda46f349f53929f888
diff --git a/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild b/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild
new file mode 100644
index 000000000000..3111bd5232ad
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-3.0.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="
+ https://github.com/jsonpickle/jsonpickle/
+ https://pypi.org/project/jsonpickle/
+"
+SRC_URI="
+ https://github.com/jsonpickle/jsonpickle/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/gmpy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e 's:--cov::' pytest.ini || die
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # problem when pandas are built with Cython 3.0.0
+ # https://github.com/jsonpickle/jsonpickle/issues/460
+ tests/pandas_test.py::test_timedelta_index_roundtrip
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged bson dependency
+ tests/bson_test.py
+ )
+ epytest
+}
+
+pkg_postinst() {
+ # Unpackaged optional backends: yajl, demjson
+ optfeature "encoding numpy-based data" dev-python/numpy
+ optfeature "encoding pandas objects" dev-python/pandas
+ optfeature "fast JSON backend" dev-python/simplejson
+}