summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-20 18:15:39 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-20 22:09:55 -0400
commit51f7f84d475e17293c4990aebf082e6049bc892d (patch)
tree5ffea3173ce4160665defea2893d81dd16aaa1d8 /dev-python/itsdangerous
parentdev-python/readme: mark s390 stable (diff)
downloadgentoo-51f7f84d475e17293c4990aebf082e6049bc892d.tar.gz
gentoo-51f7f84d475e17293c4990aebf082e6049bc892d.tar.bz2
gentoo-51f7f84d475e17293c4990aebf082e6049bc892d.zip
dev-python/itsdangerous: add python 3.7 support
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-python/itsdangerous')
-rw-r--r--dev-python/itsdangerous/itsdangerous-0.24-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/itsdangerous/itsdangerous-0.24-r1.ebuild b/dev-python/itsdangerous/itsdangerous-0.24-r1.ebuild
new file mode 100644
index 000000000000..6152888f3468
--- /dev/null
+++ b/dev-python/itsdangerous/itsdangerous-0.24-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+HOMEPAGE="https://pythonhosted.org/itsdangerous/ https://pypi.org/project/itsdangerous/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# Required for running tests.py
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -f unicode -nw --no-diffs tests.py
+ fi
+ "${PYTHON}" tests.py || die "Tests failed under ${EPYTHON}"
+}