summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-19 08:56:34 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-19 08:56:34 +0200
commit4c05955e6327a1315812b726dfec7f1436cc090e (patch)
tree33594119791a2786cbc76f5d3c979025b84bcfd6 /dev-python/httpcore
parentdev-python/socksio: initial import (diff)
downloadgentoo-4c05955e6327a1315812b726dfec7f1436cc090e.tar.gz
gentoo-4c05955e6327a1315812b726dfec7f1436cc090e.tar.bz2
gentoo-4c05955e6327a1315812b726dfec7f1436cc090e.zip
dev-python/httpcore: add 0.14.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.14.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index be406716d1ae..28b4c9816f4c 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1,4 @@
DIST httpcore-0.13.7.tar.gz 64734 BLAKE2B e6c4b1720ce4bf62689995d3e1c648c4702bb416f3b3586eb8dd2f0cfd2155046e64181c4c04e65f721a5f0fcbc23b5ffd01c2930c7c69d37ee4c36e37b7d0d4 SHA512 0cc48828d0710066b3ef89998ec85975285763ac63a8b59106952ef2dac5a02dac71e7e106c4b6ea1022eb4d06a9cb5ee3e634eb564bad49c5508beff75279d6
DIST httpcore-0.14.3.tar.gz 64650 BLAKE2B 140c55af60f54ff13db958cecef50af2b8857837c00c2e5b1ec48d8866bc08146f608864a3dcaed0014505ba0ea10b8d457a763ecf434a0d40a2e11debdd4003 SHA512 05e92109839c2e2f7ec81fea9507fb15a12d1bf6ae92048170953b1cb0139237b81c892feff1bc3840e06887e8916cadcc4124725874344524e45e3640a00379
DIST httpcore-0.14.4.tar.gz 68463 BLAKE2B cc6c17da3b97c2a8fb9edb0aeb6247904240748645f605b2f3c84194fc06bab10f568ce21b8beaf1dee9a8d68166f1691e00f17e44d89efce0a18a6fbd91d5a5 SHA512 4dfb2d0dd10df1de45f4e78ddedddf02bf500a81a0132919894bd5c07f02a2975ce589ba3f6d79dd92ec882128f86f338bd32f35cdecb6618307e446ed369310
+DIST httpcore-0.14.5.tar.gz 74227 BLAKE2B 8e54b6b40d35a9228b96682d87651a6d3967441b74f3544a21b378620b417b48978f51d25b1980d87fad4748537036c6f2a4751e8b58e622c7c76389ff1afb67 SHA512 1705cf83df3ead454065e2ed4c300697c5d0a6609846a3eadfca2af2d9c1578f951c2f4bf3ac018c3cc984d2d2ccd39c4b2de781747588a6116eebe1007afff0
diff --git a/dev-python/httpcore/httpcore-0.14.5.ebuild b/dev-python/httpcore/httpcore-0.14.5.ebuild
new file mode 100644
index 000000000000..b31862854908
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.14.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="https://www.encode.io/httpcore/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ =dev-python/anyio-3*[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.13[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKs support" dev-python/socksio
+}