summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-08 18:54:20 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-08 18:54:20 -0700
commit99d071475448abc9d4935da9f2b7b5182bd4a1f5 (patch)
tree8cacb679b5c36aced35fa0b3f82dc8d6c77d0cec /dev-python/html5lib
parentdev-python/pytest-expect: add package (diff)
downloadgentoo-99d071475448abc9d4935da9f2b7b5182bd4a1f5.tar.gz
gentoo-99d071475448abc9d4935da9f2b7b5182bd4a1f5.tar.bz2
gentoo-99d071475448abc9d4935da9f2b7b5182bd4a1f5.zip
dev-python/html5lib: version bump to 0.999999999
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/Manifest1
-rw-r--r--dev-python/html5lib/html5lib-0.999999999.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/html5lib/Manifest b/dev-python/html5lib/Manifest
index de4d9101029a..1870dc9db705 100644
--- a/dev-python/html5lib/Manifest
+++ b/dev-python/html5lib/Manifest
@@ -1 +1,2 @@
DIST html5lib-0.9999999.tar.gz 889312 SHA256 2612a191a8d5842bfa057e41ba50bbb9dcb722419d2408c78cff4758d0754868 SHA512 1748a1921f4bc93b7f208d89701eeabfe507e40515dd2e88ece239ba7c1704c8ae9dc4eea310164c7b207225dce910f78a8b34f826f4f87a2992365c07089c28 WHIRLPOOL 48dbd278e247e98e2765e7da1ce99474fba241b0a6b70e441899271b0cffffca33720646a35ae724713be5ce5a15617d611ebd76c192755e72485d09d446f5ac
+DIST html5lib-0.999999999.tar.gz 245488 SHA256 ee747c0ffd3028d2722061936b5c65ee4fe13c8e4613519b4447123fc4546298 SHA512 b30d9ea74d0ad03e07ebee0d33caefeed717e6084f2ef44559ebf73948563ffd60e40c774e23c8964a32b0f265d1d1f0b98759861acaa208f28e5ab2813c3ca0 WHIRLPOOL 369e81d83d03636b34901277f53e80373f54ecc15ae948d4a4f04554cd78815b6574759835d76e3105028803e6797a92144a1346e7c826a72269239dc5d105ee
diff --git a/dev-python/html5lib/html5lib-0.999999999.ebuild b/dev-python/html5lib/html5lib-0.999999999.ebuild
new file mode 100644
index 000000000000..6465ee9478e2
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.999999999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}