summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-29 07:51:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-29 08:19:25 +0200
commit0e25230074be4447f2471b8f44b7035cb68d923a (patch)
tree41f5295c0817d9bd84ae4f91e6c366059f275c64 /dev-python/configupdater
parentdev-python/trove-classifiers: Bump to 2022.6.26 (diff)
downloadgentoo-0e25230074be4447f2471b8f44b7035cb68d923a.tar.gz
gentoo-0e25230074be4447f2471b8f44b7035cb68d923a.tar.bz2
gentoo-0e25230074be4447f2471b8f44b7035cb68d923a.zip
dev-python/configupdater: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configupdater')
-rw-r--r--dev-python/configupdater/Manifest1
-rw-r--r--dev-python/configupdater/configupdater-3.1.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/configupdater/Manifest b/dev-python/configupdater/Manifest
index be50b3831097..526a5a05798a 100644
--- a/dev-python/configupdater/Manifest
+++ b/dev-python/configupdater/Manifest
@@ -1 +1,2 @@
+DIST configupdater-3.1.1.gh.tar.gz 138777 BLAKE2B 9fef5815bc41903a65c2c53c6b9ff3d00d1f4efe65008c725afda8d12694be4d18810cbfc03b291246789d736f1a2933061f2683bfc62e9e1d72e2e4f159d772 SHA512 1e499f87d0ac3d75f32aafe532d7c83b4b86fbaa204fcdbaf7a3dcb5262d936fe027ee0b21d169ef69a0590edbe965a872390b14be274fbb1c893f2d4695b92c
DIST configupdater-3.1.gh.tar.gz 138671 BLAKE2B 48e349780e11ca26b4b15b44aa298058840cfcea47fc7b2e555f3ca743de1956a15255bfea2c5f96624e02e399bed99ae45f3422ab1660b8ae83087ddf6117e1 SHA512 89685a93f3bec907184d818b5adea4f87967df313fe4e4216aeef2c227fdf0b0f98757ec27da7f43adff6e2ee37020dd57b98569d5811c9dc7c3201852b27432
diff --git a/dev-python/configupdater/configupdater-3.1.1.ebuild b/dev-python/configupdater/configupdater-3.1.1.ebuild
new file mode 100644
index 000000000000..bb6d09e8a58f
--- /dev/null
+++ b/dev-python/configupdater/configupdater-3.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parser like ConfigParser but for updating configuration files"
+HOMEPAGE="
+ https://github.com/pyscaffold/configupdater/
+ https://pypi.org/project/ConfigUpdater/
+"
+SRC_URI="
+ https://github.com/pyscaffold/configupdater/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT PSF-2 PYTHON"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' setup.cfg || die
+}