summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/click
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest3
-rw-r--r--dev-python/click/click-2.0.ebuild23
-rw-r--r--dev-python/click/click-4.0-r1.ebuild45
-rw-r--r--dev-python/click/click-4.1.ebuild43
-rw-r--r--dev-python/click/files/click-4.0-docbuild.patch12
-rw-r--r--dev-python/click/metadata.xml8
6 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
new file mode 100644
index 000000000000..84bb34b4d15c
--- /dev/null
+++ b/dev-python/click/Manifest
@@ -0,0 +1,3 @@
+DIST click-2.0.tar.gz 47342 SHA256 33a984fe73aa8c6bf69c38098b69dd38405529db54baf4c8cf64c50b2dee644f SHA512 4c703ab4b5c76e393420b0edf9af9e8ddb301ccfef5f8117d3408eaa8a94abe6b7b5c7a8b61b7774a3b459b153c10438e8934f21ceb73697199828cce2c2887c WHIRLPOOL bf599395245319b31c189df297a1ec35ca69723ed24e2d3e9aa9231a3cfebdb80e1f43a0b010865b6fbecf09f23dc1121cca232aec26f09bdb455f41da5261c4
+DIST click-4.0.tar.gz 270183 SHA256 f49e03611f5f2557788ceeb80710b1c67110f97c5e6740b97edf70245eea2409 SHA512 7b3b3e3b57fe74e8d2e3be79c59476fe7830c04068f0e31b39dfee28d879d8a96eed311fbe789bfc6d12c898052ea1c901c3b6f4c995cd4e0ede61b62fe0a39a WHIRLPOOL fd183c6509c3d8a3c582454aac8a18b3d570c16ca4b1cf19dbdd97d8846fde62fadd7d80596eb321a67e48477853b26cb7e5d554c9254061ab1bb74a52d3a05a
+DIST click-4.1.tar.gz 274489 SHA256 e339ed09f25e2145314c902a870bc959adcb25653a2bd5cc1b48d9f56edf8ed8 SHA512 fe751406919d06a3ccffc2831992848d8e324f0f0ca566ea3b9ed0be3298c8d1e2039643eadc71eb4dfabd790310396cd5b26a11d7b6f6cdf503f191ce6dd1cd WHIRLPOOL 3005501210fae07d3cbdd5674a22d24b577c02ba20c34fb94f3bf7011ec2d26847b7faca5fe74ca620bdc8a0c4bfaecdf5dbcf4c2f0046de76e8b13628e2910f
diff --git a/dev-python/click/click-2.0.ebuild b/dev-python/click/click-2.0.ebuild
new file mode 100644
index 000000000000..c910519ff704
--- /dev/null
+++ b/dev-python/click/click-2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# FIXME: tests docs and examples aren't being shipped with releases.
+# Asked upstream to fix this. Avoided using github snapshots for now. (rafaelmartins)
+IUSE=""
+
+RDEPEND="dev-python/colorama"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/click/click-4.0-r1.ebuild b/dev-python/click/click-4.0-r1.ebuild
new file mode 100644
index 000000000000..9ce0a97b53ca
--- /dev/null
+++ b/dev-python/click/click-4.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+PATCHES=( "${FILESDIR}"/${P}-docbuild.patch )
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ # use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/click/click-4.1.ebuild b/dev-python/click/click-4.1.ebuild
new file mode 100644
index 000000000000..0a348e7634ec
--- /dev/null
+++ b/dev-python/click/click-4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/click/files/click-4.0-docbuild.patch b/dev-python/click/files/click-4.0-docbuild.patch
new file mode 100644
index 000000000000..24ce6ce1ead0
--- /dev/null
+++ b/dev-python/click/files/click-4.0-docbuild.patch
@@ -0,0 +1,12 @@
+https://github.com/mitsuhiko/click/issues/318#issuecomment-89565131
+--- docs/options.rst
++++ docs/options.rst
+@@ -150,6 +150,7 @@
+ .. click:example::
+
+ import os
++ import sys
+
+ @click.command()
+ @click.option('--shout/--no-shout', default=False)
+
diff --git a/dev-python/click/metadata.xml b/dev-python/click/metadata.xml
new file mode 100644
index 000000000000..3f003a9288b3
--- /dev/null
+++ b/dev-python/click/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">click</remote-id>
+ </upstream>
+</pkgmetadata>