summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-21 09:48:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-21 09:57:25 +0200
commit13aa81aea7b8314b064e163b59cf4c55c61f5b99 (patch)
treed73635d8761111209630ef28b8cd9187578e1d58 /dev-python/cftime
parentdev-python/httpretty: Bump to 1.1.2 (diff)
downloadgentoo-13aa81aea7b8314b064e163b59cf4c55c61f5b99.tar.gz
gentoo-13aa81aea7b8314b064e163b59cf4c55c61f5b99.tar.bz2
gentoo-13aa81aea7b8314b064e163b59cf4c55c61f5b99.zip
dev-python/cftime: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cftime')
-rw-r--r--dev-python/cftime/Manifest1
-rw-r--r--dev-python/cftime/cftime-1.5.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/cftime/Manifest b/dev-python/cftime/Manifest
index f91546f042dd..352b400ce938 100644
--- a/dev-python/cftime/Manifest
+++ b/dev-python/cftime/Manifest
@@ -1 +1,2 @@
DIST cftime-1.4.1.tar.gz 46721 BLAKE2B 903f8c042b6f4738893ee54c9d1b862f6f29b42c67b45800d21e1215979c95d985d56eb234dd52493da331c30b2b55c5c1590b51822bb87eaada7dd2879c57b1 SHA512 2d07b8f423e9945b1ced2e89f03965df5c3b25f932b0e7ce893a6cbd4568c93f0abb1d8e6efebe2cafca2ee19259f3c0878fec4fb91f68bf5dde1ccb67bcdef9
+DIST cftime-1.5.0.tar.gz 44972 BLAKE2B 515b5025987373499af4ce7f7e1b3001112c5ce1810a7a4a7825f57163815f7784682e3cfdb97a23507848e64689d2e6433be406ca217beda513050bbc66ea8c SHA512 8607d12ac1333e47de1976b0efc96f0f2a141cff19291974300c23b35ea9e389e698de0dc8fe5303b2686c77750e8d4017670c697de16d989c689391109ec510
diff --git a/dev-python/cftime/cftime-1.5.0.ebuild b/dev-python/cftime/cftime-1.5.0.ebuild
new file mode 100644
index 000000000000..f192f36b4209
--- /dev/null
+++ b/dev-python/cftime/cftime-1.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Time-handling functionality from netcdf4-python"
+HOMEPAGE="https://pypi.org/project/cftime/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e "/--cov/d" setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}