summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-10 07:46:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-10 08:30:01 +0200
commit77008b77cb4492c41f9aeea7a80c721f666c8c41 (patch)
tree8a8c2270ab72b47d0eb23650d456f6761f6911a9 /dev-python/boto3
parentdev-python/botocore: Bump to 1.17.20 (diff)
downloadgentoo-77008b77cb4492c41f9aeea7a80c721f666c8c41.tar.gz
gentoo-77008b77cb4492c41f9aeea7a80c721f666c8c41.tar.bz2
gentoo-77008b77cb4492c41f9aeea7a80c721f666c8c41.zip
dev-python/boto3: Bump to 1.14.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.14.20.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 0c05f2ecee52..d9391abf53e8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,6 +5,7 @@ DIST boto3-1.14.0.tar.gz 297008 BLAKE2B 7f5eaf4958395b47e936596b385b5a4daa20dbed
DIST boto3-1.14.11.tar.gz 298578 BLAKE2B c78ba0957c4252adeaefb7ac3e335e3db6044752cd06731b6f7367bbfdbbb2db25d717ddf8954eabce745bca07d2980445a725977d3f12a5914e8620502e7f88 SHA512 069e21ca8aa5b7d30ff7ea9f94bb4d939495f0ce30a831e985687eafe4cd22ce830af2427b645df16ddcd51126c366ff61243bb7251a2aecbef46b8573d2e124
DIST boto3-1.14.15.tar.gz 298869 BLAKE2B 24e55039ac4a7ecb97eb2e5f61a7991422df30e089bdf1d716a5daab81df0cfec5b8fd4c543a22d4bf208351cc77c88dff2e50949d006d93a523e8287c000d40 SHA512 8f082ee1062caa38dbf4dca28a7b48125d5938f7fd1d09bb01f31bef129fcd346e99f2f18d11a67e9733d674c3c263c809800bb8e58bbe70750dcfbcaec6c731
DIST boto3-1.14.2.tar.gz 297730 BLAKE2B 174bc2435247db4421ffbf1ca0ef2cb772a9b6f357cbb438996ad635fca8ae5cd1005df3f8fdc6c63607797115c2379bb10c43edcfaf8393394f241b1e7a1ca1 SHA512 6ad539e568fe90c2f7408f37d28f194ac7094f6393858e487bf2afa73b8b53c90c8ab489bbe56f7c594351b24aaa82bfc9f81c9d68fadaecaec5acc3352fad5e
+DIST boto3-1.14.20.tar.gz 299325 BLAKE2B e1105a2ba55d59dc4d9a73f40e3bc34c05ceda906963d162eeeac8542d234a85b01e2ed485069269e923e2697b33c3f8e77af474716d8b2fa2a2f3ecf4093168 SHA512 d8f281d41386754c3720eeade23bb7b3c2b74176b5e0a763c5f355ed44e52f651d76a10dcc947142f0438be7c983bfc26ec8d31a1b341f55149188e6e7d6d1d8
DIST boto3-1.14.5.tar.gz 297919 BLAKE2B 9428ddfa1a5549bfb8319cc91292dace9245a9db94eec373f571342808cdda7c1bf2b683ccddbcae532aca79666971b5cff7646756dff7baa24e291b348ff0f0 SHA512 7c65b1a1b6070b8954b7a705b1473543be6a4939c8594327cdaf8c91ff557bfdb49611e18f2bc6b0213fc13ef4cdbf57da7e632ac93dacf6d887f7a18889ff59
DIST boto3-1.14.8.tar.gz 297922 BLAKE2B e71a74155a6e32b310063c6c80ceb960db816898271f01066099d9ef162e90c5c446ea29b7164d957cc4d02e546eec59eb62f9168aa7e5f6e149c2d97fa14928 SHA512 a5c1c63664c406dc6b923ee565d30572173084b43a4539605cfc36a959d5d8fbcf0864720732128f26ba84fe8e4aabb31842d656e6e189860a41b365955e63ae
DIST boto3-1.9.122.tar.gz 258061 BLAKE2B 68903edd97e10693675e4c2fa77c2c54f2d3aab79307ee0a856f43aabe256f7782d027b0a23f433c593962c90f7364c26a87c27fe8770e67b5052e4ced73a9bc SHA512 31b8d8c2369b9076d825196d400c8a8b5579c38f87c7f41634eedbdaf6c2be01072018312e90e25d81b850c51f7c22a13fa565cd4e8b7672c238bad61e6a0810
diff --git a/dev-python/boto3/boto3-1.14.20.ebuild b/dev-python/boto3/boto3-1.14.20.ebuild
new file mode 100644
index 000000000000..bbe6631e26ee
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.20.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit tests/functional ||
+ die "test failed under ${EPYTHON}"
+}