summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-24 05:50:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-24 06:24:00 +0200
commit0a4cd6285f2b16fabf4423b895a2ec250c97425f (patch)
tree17d308a6a88f4d721273d8b15558c37c85470cdc /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.147 (diff)
downloadgentoo-0a4cd6285f2b16fabf4423b895a2ec250c97425f.tar.gz
gentoo-0a4cd6285f2b16fabf4423b895a2ec250c97425f.tar.bz2
gentoo-0a4cd6285f2b16fabf4423b895a2ec250c97425f.zip
dev-python/boto3: Bump to 1.34.147
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.147.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 09c3101c93ad..f65f37251ae7 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.34.140.gh.tar.gz 828290 BLAKE2B 129c0f791ddc07f90d2b9ae2972839a0bca
DIST boto3-1.34.144.gh.tar.gz 840506 BLAKE2B 7fccc6ae45dec6411995795dc7dd180cec51b79f93362a221d7709f35ece2652390219d51507130fcfcedf82f0d2fa89461c112027b7d8040f84f2f907518b30 SHA512 4da24e40cb8beafd975cf21de0e548b167de59e1b47b4b005f4320d2c4cd60e0c5b72378ecdb1b21ec789b4b943df4856128890d865e0fb974a34563871a2078
DIST boto3-1.34.145.gh.tar.gz 841776 BLAKE2B e93a6c4d634c2df22ed27e58c2abe0a6cc835364b4a93c73c8c221ba39b63b89c5f3ddbf210eb90a451c9b6650061f08a173395f1fb3cd4abe8fde90347b4c63 SHA512 ebd85e3068d1ad332b2ed4c2ad45c022fadb090f8aacdcd72c0d515f91b218201afd69750281b68c909dbf2ab35bef3a39412a616f5b134780f15c0cc9854123
DIST boto3-1.34.146.gh.tar.gz 842332 BLAKE2B 1e718ca3ae9c59f8528a8e944d1a1e596a595c6ae0d1c7ec83aa47a429f03fe14f9a173772590dc1134fe64bfa471a2cfcf729db107bb19a80fa15b8d13f804a SHA512 ec1fc0bc4aa528a9f93e5ec9ce2b582b6c7c79967097f39c4eb9895486569f2953235867b7f88a593040fd614a37e05fd9d91db107e28106b6d6ff0ea1b5a0c9
+DIST boto3-1.34.147.gh.tar.gz 842874 BLAKE2B 22363cdc4acce00cce16a78a30c0121b0046f309ea9bda21a45880bf5abd19a8177ee7376393b85b3283a8a6ea27931bea21a2f97a4c59d087a4a2aff45dfc6f SHA512 90eda840237b3e968913800de4978ce6bafe3393d7076af4eacfd0851d09358859d5025daacf789b47f984a29d1036af9620f6cac9f12639a041a964ad840aee
diff --git a/dev-python/boto3/boto3-1.34.147.ebuild b/dev-python/boto3/boto3-1.34.147.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.147.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}